1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; This file is part of GNU Guix.
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages pure)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix utils)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix gexp)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages llvm)
30 #:use-module (gnu packages multiprecision))
39 (uri (string-append "https://github.com/agraef/pure-lang/releases/"
40 "download/pure-" version "/"
41 "pure-" version ".tar.gz"))
44 "0px6x5ivcdbbp2pz5n1r1cwg1syadklhjw8piqhl63n91i4r7iyb"))))
45 (build-system gnu-build-system)
47 `(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
48 (assoc-ref %outputs "out")
51 (modify-phases %standard-phases
52 (add-after 'unpack 'patch-llvm-lookup
54 (substitute* "configure"
55 (("-lLLVM-[$][{]llvm_version[}]")
56 "`$LLVMCONF --libs`"))
62 (home-page "https://agraef.github.io/pure-lang/")
63 (synopsis "Pure programming Language")
64 (description "@code{pure} is a programming language based on term
65 rewriting. It offers equational definitions with pattern matching,
66 full symbolic rewriting capabilities, dynamic typing, eager and lazy
67 evaluation, lexical closures, built-in list and matrix support and
69 (license license:gpl3+)))