doc: Update htmlxref.cnf.
[guix.git] / gnu / packages / mastodon.scm
blob028745f6817084a462299787b23ae376f37ba2c7
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages mastodon)
20   #:use-module (guix packages)
21   #:use-module (guix download)
22   #:use-module (guix build-system python)
23   #:use-module ((guix licenses) #:prefix license:)
24   #:use-module (gnu packages check)
25   #:use-module (gnu packages python-web)
26   #:use-module (gnu packages python-xyz)
29 (define-public toot
30   (package
31     (name "toot")
32     (version "0.21.0")
33     (source
34       (origin
35         (method url-fetch)
36         (uri (pypi-uri "toot" version))
37         (sha256
38          (base32
39           "1dqv5jckaw3r7dnfns3iygwbfnf27x513qrw2rryzl5y79xrzs1x"))))
40     (build-system python-build-system)
41     (arguments
42      '(#:phases
43        (modify-phases %standard-phases
44          (delete 'check)
45          (add-after 'install 'check
46            (lambda* (#:key inputs outputs #:allow-other-keys)
47              (add-installed-pythonpath inputs outputs)
48              (invoke "py.test"))))))
49     (native-inputs
50      `(("python-pytest" ,python-pytest)))
51     (propagated-inputs
52      `(("python-beautifulsoup4" ,python-beautifulsoup4)
53        ("python-requests" ,python-requests)
54        ("python-wcwidth" ,python-wcwidth)))
55     (home-page "https://github.com/ihabunek/toot/")
56     (synopsis "Mastodon CLI client")
57     (description "Interact with Mastodon social network from the command line.
58 Features include:
59 @itemize
60 @item Posting, replying, deleting statuses
61 @item Support for media uploads, spoiler text, sensitive content
62 @item Search by account or hash tag
63 @item Following, muting and blocking accounts
64 @item Simple switching between authenticated in Mastodon accounts
65 @end itemize")
66     (license license:gpl3)))