1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
3 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
4 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; This file is part of GNU Guix.
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23 (define-module (gnu packages kde-plasma)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix build-system cmake)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages freedesktop)
30 #:use-module (gnu packages glib)
31 #:use-module (gnu packages kde-frameworks)
32 #:use-module (gnu packages linux)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages qt)
35 #:use-module (gnu packages xorg))
37 (define-public kdecoration
43 (uri (string-append "mirror://kde/stable/plasma/" version
44 "/kdecoration-" version ".tar.xz"))
47 "03lxnjbhlnyiw2znflp0f2w77a5pzv5yvsbngvwgp89ig9mansi1"))))
48 (build-system cmake-build-system)
50 `(("extra-cmake-modules" ,extra-cmake-modules)))
56 (modify-phases %standard-phases
57 (add-before 'check 'check-setup
58 (lambda _ (setenv "QT_QPA_PLATFORM" "offscreen") #t)))))
59 (home-page "https://cgit.kde.org/kdecoration.git")
60 (synopsis "Plugin based library to create window decorations")
61 (description "KDecoration is a library to create window decorations.
62 These window decorations can be used by for example an X11 based window
63 manager which re-parents a Client window to a window decoration frame.")
64 (license license:lgpl3+)))
66 (define-public kscreenlocker
68 (name "kscreenlocker")
72 (uri (string-append "mirror://kde/stable/plasma/" version
73 "/kscreenlocker-" version ".tar.xz"))
76 "1jp2z1wjsd99is31igkfnscs55h755cmp86ppkj596fcxv1krymq"))))
77 (build-system cmake-build-system)
80 (modify-phases %standard-phases
81 (add-before 'check 'check-setup
82 (lambda* (#:key inputs outputs #:allow-other-keys)
83 (system (string-append (assoc-ref inputs "xorg-server")
84 "/bin/Xvfb :1 -screen 0 640x480x24 &"))
85 (setenv "DISPLAY" ":1")
88 ;; Tests use the installed library and require a DBus session.
89 (add-after 'install 'check
91 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
92 (invoke "dbus-launch" "ctest" "."))))))
94 `(("extra-cmake-modules" ,extra-cmake-modules)
95 ("pkg-config" ,pkg-config)
99 ("xorg-server" ,xorg-server)))
101 `(("kcmutils" ,kcmutils)
103 ("kdeclarative" ,kdeclarative)
104 ("kglobalaccel" ,kglobalaccel)
106 ("kidletime" ,kidletime)
107 ("knotifications" ,knotifications)
108 ("ktextwidgets" ,ktextwidgets)
109 ("kwayland" ,kwayland)
110 ("kwindowsystem" ,kwindowsystem)
112 ("libseccomp" ,libseccomp) ;for sandboxing the look'n'feel package
113 ("libxcursor" ,libxcursor) ;missing in CMakeList.txt
114 ("libxi" ,libxi) ;XInput, required for grabbing XInput2 devices
115 ("linux-pam" ,linux-pam)
116 ("logind" ,elogind) ;optional loginctl support
118 ("qtdeclarative" ,qtdeclarative)
119 ("qtx11extras" ,qtx11extras)
122 ("xcb-util-keysyms" ,xcb-util-keysyms)))
123 (home-page "https://cgit.kde.org/kscreenlocker.git")
124 (synopsis "Screen locking library")
126 "@code{kscreenlocker} is a library for creating secure lock screens.")
127 (license license:gpl2+)))
129 (define-public libkscreen
136 (uri (string-append "mirror://kde/stable/plasma/" version "/"
137 name "-" version ".tar.xz"))
139 (base32 "1zpzqafrb576al10f5873nl1z135gscjza6gd3ickfzlvd9qmr18"))))
140 (build-system cmake-build-system)
142 `(("extra-cmake-modules" ,extra-cmake-modules)
146 `(("kwayland" ,kwayland)
147 ("libxrandr" ,libxrandr)
149 ("qtx11extras" ,qtx11extras)))
151 '(#:tests? #f ; FIXME: 55% tests passed, 5 tests failed out of 11
153 (modify-phases %standard-phases
154 (add-before 'check 'pre-check
156 ;; For the missing '/etc/machine-id'.
157 (setenv "DBUS_FATAL_WARNINGS" "0")
158 ;; Run the tests offscreen.
159 (setenv "QT_QPA_PLATFORM" "offscreen")
161 (home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
162 (synopsis "KDE's screen management software")
163 (description "KScreen is the new screen management software for KDE Plasma
164 Workspaces which tries to be as magic and automatic as possible for users with
165 basic needs and easy to configure for those who want special setups.")
166 (license license:gpl2+)))
168 (define-public libksysguard
170 (name "libksysguard")
175 (uri (string-append "mirror://kde//stable/plasma/" version
176 "/libksysguard-" version ".tar.xz"))
179 "0ml106yq4q9qagkrcaafgcky18wk76px5a1r6j36wfjqdd6wpzvs"))))
181 `(("extra-cmake-modules" ,extra-cmake-modules)
182 ("pkg-config" ,pkg-config)))
184 `(("kconfigwidgets" ,kconfigwidgets)
185 ("kiconthemes" ,kiconthemes)
186 ("kwindowsystem" ,kwindowsystem)
189 ("kcompletion" ,kcompletion)
191 ("kcoreaddons" ,kcoreaddons)
192 ("kglobalaccel" ,kglobalaccel)
194 ("kwidgetsaddons" ,kwidgetsaddons)
195 ("kservice" ,kservice)
197 ("qtscript" ,qtscript)
198 ("qtwebkit" ,qtwebkit)
199 ("qtx11extras" ,qtx11extras)
200 ("plasma" ,plasma-framework)
202 (build-system cmake-build-system)
205 `(,(string-append "-DKDE_INSTALL_DATADIR="
206 (assoc-ref %outputs "out") "/share"))
208 (modify-phases %standard-phases
209 (add-before 'configure 'patch-cmakelists
211 ;; TODO: Verify: This should no longer be necessary, since
212 ;; KF5AuthConfig.cmake.in contains this already.
213 (substitute* "processcore/CMakeLists.txt"
214 (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
215 (add-before 'check 'check-setup
217 ;; make Qt render "offscreen", required for tests
218 (setenv "QT_QPA_PLATFORM" "offscreen")))
221 ;; TODO: Fix this failing test-case
222 (invoke "ctest" "-E" "processtest"))))))
223 (home-page "https://userbase.kde.org/KSysGuard")
224 (synopsis "Network enabled task and system monitoring")
225 (description "KSysGuard can obtain information on system load and
226 manage running processes. It obtains this information by interacting
227 with a ksysguardd daemon, which may also run on a remote system.")
228 (license license:gpl3+)))