doc: Update htmlxref.cnf.
[guix.git] / gnu / packages / jrnl.scm
blob6393ea910571a6253bbba148b614efaefeb19952
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <address@hidden>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
21 (define-module (gnu packages jrnl)
22   #:use-module (guix packages)
23   #:use-module (guix licenses)
24   #:use-module (guix download)
25   #:use-module (guix build-system python)
26   #:use-module (gnu packages check)
27   #:use-module (gnu packages python)
28   #:use-module (gnu packages python-crypto)
29   #:use-module (gnu packages python-xyz)
30   #:use-module (gnu packages time))
32 (define-public jrnl
33   (package
34     (name "jrnl")
35     (version "1.9.7")
36     (source
37      (origin
38       (method url-fetch)
39       (uri (string-append "https://github.com/maebert/jrnl/archive/"
40                           version ".tar.gz"))
41       (file-name (string-append name "-" version ".tar.gz"))
42       (sha256
43        (base32
44         "0mfq7hhw5np2dj9jlxpyyk2cg9i0xgz2brb894d928hczszy97bq"))))
45     (build-system python-build-system)
46     (native-inputs
47      `(("behave" ,behave)))
48     (inputs
49      `(("python" ,python)
50        ("python-keyring" ,python-keyring)
51        ("python-pycrypto" ,python-pycrypto)
52        ("python-pytz" ,python-pytz)
53        ("python-tzlocal" ,python-tzlocal)
54        ("python-six" ,python-six)
55        ("python-dateutil" ,python-dateutil)
56        ("python-parsedatetime" ,python-parsedatetime)))
57     (home-page "http://maebert.github.io/jrnl/")
58     (synopsis "Personal journal application")
59     (description
60      "Jrnl is a command line journal application that stores your journal in a
61 plain text file.  Optionally, your journal can be encrypted using 256-bit AES
62 encryption.")
63     (license x11)))