doc: Update htmlxref.cnf.
[guix.git] / gnu / packages / idutils.scm
blob81715591b42775e2fc0bb8238fcfd52c4f0c0bfb
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 208 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages idutils)
21   #:use-module (guix packages)
22   #:use-module (guix download)
23   #:use-module (guix build-system gnu)
24   #:use-module (guix licenses)
25   #:use-module (gnu packages emacs)
26   #:use-module (gnu packages))
28 (define-public idutils
29   (package
30     (name "idutils")
31     (version "4.6")
32     (source (origin
33              (method url-fetch)
34              (uri (string-append "mirror://gnu/idutils/idutils-"
35                                  version ".tar.xz"))
36              (sha256
37               (base32
38                "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1"))
39              (patches (search-patches "diffutils-gets-undeclared.patch"))
40              (modules '((guix build utils)))
41              (snippet
42               '(begin
43                  (substitute* (find-files "lib" "\\.c$")
44                    (("#if defined _IO_ftrylockfile")
45                     "#if defined _IO_EOF_SEEN"))
46                  (substitute* "lib/stdio-impl.h"
47                    (("^/\\* BSD stdio derived implementations")
48                     (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
49                                    "# define _IO_IN_BACKUP 0x100\n"
50                                    "#endif\n\n"
51                                    "/* BSD stdio derived implementations")))
52                  #t))))
53     (build-system gnu-build-system)
54     (native-inputs `(("emacs" ,emacs-minimal)))
55     (home-page "https://www.gnu.org/software/idutils/")
56     (synopsis "Identifier database utilities")
57     (description
58      "The GNU idutils package includes tools to create an index of textual
59 tokens used in a list of file names and then to query that index.  Thus, it
60 allows the user to, for example, find all the uses of a particular function
61 in a large programming project.  In addition to handling textual tokens, it
62 can also handle numeric constants and the contents of character strings.")
63     (license gpl3+)))