1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;; This file is part of GNU Guix.
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21 (define-module (gnu packages gdb)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages ncurses)
24 #:use-module (gnu packages readline)
25 #:use-module (gnu packages dejagnu)
26 #:use-module (gnu packages texinfo)
27 #:use-module (gnu packages multiprecision)
28 #:use-module (gnu packages xml)
29 #:use-module (gnu packages guile)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages pkg-config)
32 #:use-module ((guix licenses) #:select (gpl3+))
33 #:use-module (guix packages)
34 #:use-module (guix download)
35 #:use-module (guix build-system gnu))
43 (uri (string-append "mirror://gnu/gdb/gdb-"
47 "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))
48 (build-system gnu-build-system)
50 `(#:tests? #f ; FIXME "make check" fails on single-processor systems.
52 #:modules ((srfi srfi-1)
53 ,@%gnu-build-system-modules)
55 #:phases (modify-phases %standard-phases
57 'configure 'post-configure
59 (for-each patch-makefile-SHELL
60 (find-files "." "Makefile\\.in"))
63 'install 'remove-libs-already-in-binutils
64 (lambda* (#:key inputs outputs #:allow-other-keys)
65 ;; Like Binutils, GDB installs libbfd, libopcodes, etc.
66 ;; However, this leads to collisions when both are
67 ;; installed, and really is none of its business,
68 ;; conceptually. So remove them.
69 (let* ((binutils (assoc-ref inputs "binutils"))
70 (out (assoc-ref outputs "out"))
71 (files1 (with-directory-excursion binutils
72 (append (find-files "lib")
73 (find-files "include"))))
74 (files2 (with-directory-excursion out
75 (append (find-files "lib")
76 (find-files "include"))))
77 (common (lset-intersection string=?
79 (with-directory-excursion out
80 (for-each delete-file common)
86 ("readline" ,readline)
90 ("python-wrapper" ,python-wrapper)
93 ;; Allow use of XML-formatted syscall information. This enables 'catch
94 ;; syscall' and similar commands.
95 ("libxml2" ,libxml2)))
97 `(("texinfo" ,texinfo)
98 ("pkg-config" ,pkg-config)))
99 (home-page "https://www.gnu.org/software/gdb/")
100 (synopsis "The GNU debugger")
102 "GDB is the GNU debugger. With it, you can monitor what a program is
103 doing while it runs or what it was doing just before a crash. It allows you
104 to specify the runtime conditions, to define breakpoints, and to change how
105 the program is running to try to fix bugs. It can be used to debug programs
106 written in C, C++, Ada, Objective-C, Pascal and more.")