doc: Update htmlxref.cnf.
[guix.git] / gnu / packages / entr.scm
blobd0111452df842455876d99173c7e7e3cbea9c4ea
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
3 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
22 (define-module (gnu packages entr)
23   #:use-module (guix licenses)
24   #:use-module (guix packages)
25   #:use-module (guix download)
26   #:use-module (guix build-system gnu))
28 (define-public entr
29   (package
30     (name "entr")
31     (version "4.2")
32     (source (origin
33               (method url-fetch)
34               (uri (string-append "http://entrproject.org/code/entr-"
35                                   version ".tar.gz"))
36               (sha256
37                (base32
38                 "0w2xkf77jikcjh15fp9g7661ss30pz3jbnh261vqpaqavwah4c17"))))
39     (build-system gnu-build-system)
40     (arguments
41      `(#:test-target "test"
42        #:phases
43        (modify-phases %standard-phases
44          (replace 'configure
45            (lambda* (#:key outputs #:allow-other-keys)
46              (let ((out (assoc-ref outputs "out")))
47                (setenv "CONFIG_SHELL" (which "bash"))
48                (setenv "CC" (which "gcc"))
49                (setenv "DESTDIR" (string-append out "/"))
50                (setenv "PREFIX" "")
51                (setenv "MANPREFIX" "man")
52                (invoke "./configure"))))
53          (add-before 'build 'remove-fhs-file-names
54            (lambda _
55              ;; Use the tools available in $PATH.
56              (substitute* "entr.c"
57                (("/bin/cat") "cat")
58                (("/usr/bin/clear") "clear"))
59              #t)))))
60     (home-page "http://entrproject.org/")
61     (synopsis "Run arbitrary commands when files change")
62     (description
63      "entr is a zero-configuration tool with no external build or run-time
64 dependencies.  The interface to entr is not only minimal, it aims to be simple
65 enough to create a new category of ad hoc automation.  These micro-tests
66 reduce keystrokes, but more importantly they emphasize the utility of
67 automated checks.")
69     ;; Per 'LICENSE', portability code under missing/ is under BSD-2.
70     (license isc)))