doc: Update htmlxref.cnf.
[guix.git] / gnu / packages / dvtm.scm
blobaf16aa8f9199f1193f8d97ed36ddddf96aa6fd8b
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages dvtm)
20   #:use-module (guix build-system gnu)
21   #:use-module (guix download)
22   #:use-module (guix licenses)
23   #:use-module (guix packages)
24   #:use-module (gnu packages ncurses))
26 (define-public dvtm
27   (package
28    (name "dvtm")
29    (version "0.15")
30    (source (origin
31             (method url-fetch)
32             (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-"
33                                  version ".tar.gz"))
34             (sha256
35              (base32
36               "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g"))))
37    (build-system gnu-build-system)
38    (arguments
39     `(#:make-flags (list "CC=gcc"
40                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
41       #:phases (modify-phases %standard-phases
42                  (delete 'configure)
43                  (delete 'check))))  ; no test suite
44    (inputs `(("ncurses" ,ncurses)))
45    (synopsis "Tiling window management for the console")
46    (description "dvtm brings the concept of tiling window management,
47 popularized by X11-window managers like dwm, to the console.  As a console
48 window manager it tries to make it easy to work with multiple console based
49 programs.")
50    (home-page "http://www.brain-dump.org/projects/dvtm/")
52    ;; "dvtm reuses some code of dwm and is released under the same MIT/X11
53    ;; license. The terminal emulation part is licensed under the ISC license."
54    ;; source: http://www.brain-dump.org/projects/dvtm/#license
55    (license (list expat isc))))