doc: Update htmlxref.cnf.
[guix.git] / gnu / packages / augeas.scm
blobfcba5bae7b8fbcd5d7c84f9a16d5e009cb6ffc1c
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
21 (define-module (gnu packages augeas)
22   #:use-module ((guix licenses) #:prefix license:)
23   #:use-module (guix packages)
24   #:use-module (guix download)
25   #:use-module (guix utils)
26   #:use-module (guix build-system gnu)
27   #:use-module (gnu packages)
28   #:use-module (gnu packages readline)
29   #:use-module (gnu packages pkg-config)
30   #:use-module (gnu packages xml))
32 (define-public augeas
33   (package
34     (name "augeas")
35     (version "1.11.0")
36     (source (origin
37               (method url-fetch)
38               (uri (string-append "http://download.augeas.net/augeas-"
39                                   version ".tar.gz"))
40               (sha256
41                (base32
42                 "1c507qj6dfn2dnsl27w94zs9r45xrgm07y8bqba9ry2s0psfhg1r"))))
43     (build-system gnu-build-system)
44     ;; Marked as "required" in augeas.pc
45     (propagated-inputs
46      `(("libxml2" ,libxml2)))
47     (inputs
48      `(("readline" ,readline)))
49     (native-inputs
50      `(("pkg-config" ,pkg-config)))
51     (home-page "http://augeas.net/")
52     (synopsis "Edit configuration files programmatically")
53     (description
54      "Augeas is a library and command line tool for programmatically editing
55 configuration files in a controlled manner.  Augeas exposes a tree of all
56 configuration settings and a simple local API for manipulating the tree.
57 Augeas then modifies underlying configuration files according to the changes
58 that have been made to the tree; it does as little modeling of configurations
59 as possible, and focuses exclusivley on transforming the tree-oriented syntax
60 of its public API to the myriad syntaxes of individual configuration files.")
61     (license license:lgpl2.1+)))