1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
4 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
5 ;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
6 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
8 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
9 ;;; Copyright © 2017, 2018 Nils Gillmann <ng0@n0.is>
10 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
12 ;;; Copyright © 2019 Meiyo Peng <meiyo.peng@gmail.com>
14 ;;; This file is part of GNU Guix.
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29 (define-module (gnu packages shells)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages bash)
34 #:use-module (gnu packages bison)
35 #:use-module (gnu packages documentation)
36 #:use-module (gnu packages groff)
37 #:use-module (gnu packages libbsd)
38 #:use-module (gnu packages libedit)
39 #:use-module (gnu packages ncurses)
40 #:use-module (gnu packages pcre)
41 #:use-module (gnu packages perl)
42 #:use-module (gnu packages pkg-config)
43 #:use-module (gnu packages python)
44 #:use-module (gnu packages python-xyz)
45 #:use-module (gnu packages readline)
46 #:use-module (gnu packages scheme)
47 #:use-module (guix build-system gnu)
48 #:use-module (guix build-system python)
49 #:use-module (guix build-system trivial)
50 #:use-module (guix download)
51 #:use-module (guix git-download)
52 #:use-module (guix licenses)
53 #:use-module (guix packages))
62 (uri (string-append "http://gondor.apana.org.au/~herbert/dash/files/"
63 "dash-" version ".tar.gz"))
66 "0wb0bwmqc661hylqcfdp7l7x12myw3vpqk513ncyqrjwvhckjriw"))
67 (modules '((guix build utils)))
70 ;; The man page hails from BSD, where (d)ash is the default shell.
71 ;; This isn't the case on Guix or indeed most other GNU systems.
72 (substitute* "src/dash.1"
73 (("the standard command interpreter for the system")
74 "a command interpreter based on the original Bourne shell"))
76 (build-system gnu-build-system)
78 `(("libedit" ,libedit)))
80 '(#:configure-flags '("--with-libedit")))
81 (home-page "http://gondor.apana.org.au/~herbert/dash")
82 (synopsis "POSIX-compliant shell optimised for size")
84 "dash is a POSIX-compliant @command{/bin/sh} implementation that aims to be
85 as small as possible, often without sacrificing speed. It is faster than the
86 GNU Bourne-Again Shell (@command{bash}) at most scripted tasks. dash is a
87 direct descendant of NetBSD's Almquist Shell (@command{ash}).")
89 gpl2+)))) ; mksignames.c
98 (uri (string-append "https://github.com/fish-shell/fish-shell/"
99 "releases/download/" version "/"
100 name "-" version ".tar.gz"))
102 (base32 "03j3jl9jzlnhq4p86zj8wqsh5sx45j1d1fvfa80ks1cfdg68qwhl"))))
103 (build-system gnu-build-system)
105 `(("fish-foreign-env" ,fish-foreign-env)
106 ("groff" ,groff) ; for 'fish --help'
108 ("pcre2" ,pcre2) ; don't use the bundled PCRE2
109 ("python" ,python))) ; for fish_config and manpage completions
111 `(("doxygen" ,doxygen)))
113 '(#:tests? #f ; no check target
115 (modify-phases %standard-phases
116 (add-after 'unpack 'patch-source
118 (substitute* '("build_tools/build_commands_hdr.sh"
119 "build_tools/build_user_doc.sh")
120 (("/usr/bin/env") "env"))
122 ;; Embed absolute paths.
123 (add-before 'install 'embed-absolute-paths
125 (substitute* '("share/functions/__fish_config_interactive.fish"
126 "share/functions/fish_config.fish"
127 "share/functions/fish_update_completions.fish")
128 (("python3") (which "python3")))
129 (substitute* "share/functions/__fish_print_help.fish"
130 (("nroff") (which "nroff")))
132 ;; Source /etc/fish/config.fish from $__fish_sysconf_dir/config.fish.
133 (add-before 'install 'patch-fish-config
135 (let ((port (open-file "etc/config.fish" "a")))
136 (display (string-append
138 "# Patched by Guix.\n"
139 "# Source /etc/fish/config.fish.\n"
140 "if test -f /etc/fish/config.fish\n"
141 " source /etc/fish/config.fish\n"
146 ;; Enable completions, functions and configurations in user's and
147 ;; system's guix profiles by adding them to __extra_* variables.
148 (add-before 'install 'patch-fish-extra-paths
150 (let ((port (open-file "share/__fish_build_paths.fish" "a")))
154 "# Patched by Guix.\n"
155 "# Enable completions, functions and configurations in user's"
156 " and system's guix profiles by adding them to __extra_*"
158 "set -l __guix_profile_paths ~/.guix-profile"
159 " /run/current-system/profile\n"
160 "set __extra_completionsdir"
161 " $__guix_profile_paths\"/etc/fish/completions\""
162 " $__guix_profile_paths\"/share/fish/vendor_completions.d\""
163 " $__extra_completionsdir\n"
164 "set __extra_functionsdir"
165 " $__guix_profile_paths\"/etc/fish/functions\""
166 " $__guix_profile_paths\"/share/fish/vendor_functions.d\""
167 " $__extra_functionsdir\n"
168 "set __extra_confdir"
169 " $__guix_profile_paths\"/etc/fish/conf.d\""
170 " $__guix_profile_paths\"/share/fish/vendor_conf.d\""
171 " $__extra_confdir\n")
175 ;; Use fish-foreign-env to source /etc/profile.
176 (add-before 'install 'source-etc-profile
177 (lambda* (#:key inputs #:allow-other-keys)
178 (let ((port (open-file "share/__fish_build_paths.fish" "a")))
182 "# Patched by Guix.\n"
183 "# Use fish-foreign-env to source /etc/profile.\n"
184 "if status is-login\n"
185 " set fish_function_path "
186 (assoc-ref inputs "fish-foreign-env") "/share/fish/functions"
187 " $__fish_datadir/functions\n"
188 " fenv source /etc/profile\n"
189 " set -e fish_function_path\n"
194 (synopsis "The friendly interactive shell")
196 "Fish (friendly interactive shell) is a shell focused on interactive use,
197 discoverability, and friendliness. Fish has very user-friendly and powerful
198 tab-completion, including descriptions of every completion, completion of
199 strings with wildcards, and many completions for specific commands. It also
200 has extensive and discoverable help. A special @command{help} command gives
201 access to all the fish documentation in your web browser. Other features
202 include smart terminal handling based on terminfo, an easy to search history,
203 and syntax highlighting.")
204 (home-page "https://fishshell.com/")
207 (define-public fish-foreign-env
209 (name "fish-foreign-env")
210 (version "0.20190116")
215 (url "https://github.com/oh-my-fish/plugin-foreign-env.git")
216 (commit "dddd9213272a0ab848d474d0cbde12ad034e65bc")))
217 (file-name (git-file-name name version))
219 (base32 "00xqlyl3lffc5l0viin1nyp819wf81fncqyz87jx8ljjdhilmgbs"))))
220 (build-system trivial-build-system)
222 '(#:modules ((guix build utils))
225 (use-modules (guix build utils))
226 (let* ((source (assoc-ref %build-inputs "source"))
227 (out (assoc-ref %outputs "out"))
228 (func-path (string-append out "/share/fish/functions")))
230 (copy-recursively (string-append source "/functions")
233 ;; Embed absolute paths.
234 (substitute* `(,(string-append func-path "/fenv.fish")
235 ,(string-append func-path "/fenv.apply.fish")
236 ,(string-append func-path "/fenv.main.fish"))
238 (string-append (assoc-ref %build-inputs "bash") "/bin/bash"))
240 (string-append (assoc-ref %build-inputs "sed") "/bin/sed"))
242 (string-append " " (assoc-ref %build-inputs "coreutils")
246 ("coreutils" ,coreutils)
248 (home-page "https://github.com/oh-my-fish/plugin-foreign-env")
249 (synopsis "Foreign environment interface for fish shell")
250 (description "@code{fish-foreign-env} wraps bash script execution in a way
251 that environment variables that are exported or modified get imported back
262 (url "https://github.com/rakitzis/rc.git")
263 (commit (string-append "v" version))))
266 "0vj1h4pcg13vxsiydmmk87dr2sra9h4gwx0c4q6fjsiw4in78rrd"))
267 (file-name (git-file-name name version))))
268 (build-system gnu-build-system)
273 (modify-phases %standard-phases
274 (add-before 'bootstrap 'patch-trip.rc
276 (substitute* "trip.rc"
277 (("/bin/pwd") (which "pwd"))
278 (("/bin/sh") (which "sh"))
279 (("/bin/rm") (which "rm"))
280 (("/bin\\)") (string-append (dirname (which "rm")) ")")))
282 (inputs `(("readline" ,readline)
284 (native-inputs `(("autoconf" ,autoconf)
285 ("automake" ,automake)
287 ("pkg-config" ,pkg-config)))
288 (synopsis "Alternative implementation of the rc shell by Byron Rakitzis")
290 "This is a reimplementation by Byron Rakitzis of the Plan 9 shell. It
291 has a small feature set similar to a traditional Bourne shell.")
292 (home-page "https://github.com/rakitzis/rc")
302 (uri (string-append "https://github.com/wryun/es-shell/releases/"
303 "download/v" version "/es-" version ".tar.gz"))
306 "1fplzxc6lncz2lv2fyr2ig23rgg5j96rm2bbl1rs28mik771zd5h"))
307 (file-name (string-append name "-" version ".tar.gz"))))
308 (build-system gnu-build-system)
310 `(#:test-target "test"
312 (modify-phases %standard-phases
313 (add-before 'configure 're-enter-rootdir
314 ;; The tarball has no folder.
318 `(("readline" ,readline)))
321 (synopsis "Extensible shell with higher-order functions")
323 "Es is an extensible shell. The language was derived from the Plan 9
324 shell, rc, and was influenced by functional programming languages, such as
325 Scheme, and the Tcl embeddable programming language. This implementation is
326 derived from Byron Rakitzis's public domain implementation of rc, and was
327 written by Paul Haahr and Byron Rakitzis.")
328 (home-page "https://wryun.github.io/es-shell/")
329 (license public-domain)))
337 ;; Old tarballs are moved to old/.
338 (uri (list (string-append "ftp://ftp.astron.com/pub/tcsh/"
339 "tcsh-" version ".tar.gz")
340 (string-append "ftp://ftp.astron.com/pub/tcsh/"
341 "old/tcsh-" version ".tar.gz")))
344 "17ggxkkn5skl0v1x0j6hbv5l0sgnidfzwv16992sqkdm983fg7dq"))
345 (patches (search-patches "tcsh-fix-autotest.patch"
346 "tcsh-fix-out-of-bounds-read.patch"))
347 (patch-flags '("-p0"))))
348 (build-system gnu-build-system)
350 `(("autoconf" ,autoconf)
353 `(("ncurses" ,ncurses)))
356 (modify-phases %standard-phases
357 (add-before 'check 'patch-test-scripts
360 (substitute* '("tests/commands.at" "tests/variables.at")
361 (("/bin/pwd") (which "pwd")))
362 ;; The .at files create shell scripts without shebangs. Erk.
363 (substitute* "tests/commands.at"
364 (("./output.sh") "/bin/sh output.sh"))
365 (substitute* "tests/syntax.at"
366 (("; other_script.csh") "; /bin/sh other_script.csh"))
367 ;; Now, let's generate the test suite and patch it
368 (invoke "make" "tests/testsuite")
370 ;; This file is ISO-8859-1 encoded.
371 (with-fluids ((%default-port-encoding #f))
372 (substitute* "tests/testsuite"
373 (("/bin/sh") (which "sh"))))
375 (add-after 'install 'post-install
376 (lambda* (#:key inputs outputs #:allow-other-keys)
377 (let* ((out (assoc-ref %outputs "out"))
378 (bin (string-append out "/bin")))
379 (with-directory-excursion bin
380 (symlink "tcsh" "csh"))
382 (home-page "http://www.tcsh.org/")
383 (synopsis "Unix shell based on csh")
385 "Tcsh is an enhanced, but completely compatible version of the Berkeley
386 UNIX C shell (csh). It is a command language interpreter usable both as an
387 interactive login shell and a shell script command processor. It includes a
388 command-line editor, programmable word completion, spelling correction, a
389 history mechanism, job control and a C-like syntax.")
398 (uri (list (string-append
399 "https://www.zsh.org/pub/zsh-" version
402 "https://www.zsh.org/pub/old/zsh-" version
406 "17iffliqcj4hv91g0bd2sxsyfcz51mfyh97sp2iyrs2p0mndc2x5"))))
407 (build-system gnu-build-system)
408 (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
410 (modify-phases %standard-phases
411 (add-before 'configure 'fix-sh
413 ;; Some of the files are ISO-8859-1 encoded.
414 (with-fluids ((%default-port-encoding #f))
420 "Config/installfns.sh"
422 "Test/E01options.ztst"
423 "Test/A05execution.ztst"
424 "Test/A01grammar.ztst"
425 "Test/A06assign.ztst"
426 "Test/B02typeset.ztst"
427 "Completion/Unix/Command/_init_d"
429 (("/bin/sh") (which "sh"))))))
430 (add-before 'check 'patch-test
432 ;; In Zsh, `command -p` searches a predefined set of
433 ;; paths that don't exist in the build environment. See
434 ;; the assignment of 'path' in Src/init.c'
435 (substitute* "Test/A01grammar.ztst"
436 (("command -pv") "command -v")
437 (("command -p") "command ")
438 (("'command' -p") "'command' "))
440 (native-inputs `(("autoconf" ,autoconf)))
441 (inputs `(("ncurses" ,ncurses)
444 (synopsis "Powerful shell for interactive use and scripting")
445 (description "The Z shell (zsh) is a Unix shell that can be used
446 as an interactive login shell and as a powerful command interpreter
447 for shell scripting. Zsh can be thought of as an extended Bourne shell
448 with a large number of improvements, including some features of bash,
450 (home-page "https://www.zsh.org/")
452 ;; The whole thing is under an MIT/X11-style license, but there's one
453 ;; command, 'Completion/Unix/Command/_darcs', which is under GPLv2+.
463 (uri (pypi-uri "xonsh" version))
466 "0c2bbmdg0n10q54vq9k1z5n53l0mh1hb1q5xprfhilvrbr6hlcwr"))
467 (modules '((guix build utils)))
470 ;; Delete bundled ply.
471 (delete-file-recursively "xonsh/ply")
472 (substitute* '("setup.py")
473 (("'xonsh\\.ply\\.ply',") ""))
475 (build-system python-build-system)
477 '(;; TODO Try running run the test suite.
478 ;; See 'requirements-tests.txt' in the source distribution for more
482 `(("python-ply" ,python-ply)))
483 (home-page "http://xon.sh/")
484 (synopsis "Python-ish shell")
486 "Xonsh is a Python-ish, BASHwards-looking shell language and command
487 prompt. The language is a superset of Python 3.4+ with additional shell
488 primitives that you are used to from Bash and IPython. It works on all major
489 systems including Linux, Mac OSX, and Windows. Xonsh is meant for the daily
490 use of experts and novices alike.")
494 (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
498 (version (string-append "0.0.0-" revision "." (string-take commit 7)))
503 (url "https://github.com/scheme/scsh")
505 (file-name (string-append name "-" version "-checkout"))
508 "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))))
509 (build-system gnu-build-system)
511 `(#:test-target "test"
513 (modify-phases %standard-phases
514 (add-before 'configure 'replace-rx
515 (lambda* (#:key inputs #:allow-other-keys)
516 (let* ((rx (assoc-ref inputs "scheme48-rx"))
517 (rxpath (string-append rx "/share/scheme48-"
518 ,(package-version scheme48)
520 (delete-file-recursively "rx")
521 (symlink rxpath "rx"))
524 `(("scheme48" ,scheme48)
525 ("scheme48-rx" ,scheme48-rx)))
527 `(("autoconf" ,autoconf)
528 ("automake" ,automake)))
529 (home-page "https://github.com/scheme/scsh")
530 (synopsis "Unix shell embedded in Scheme")
532 "Scsh is a Unix shell embedded in Scheme. Scsh has two main
533 components: a process notation for running programs and setting up pipelines
534 and redirections, and a complete syscall library for low-level access to the
538 (define-public linenoise
539 (let ((commit "2105ce445821381cf1bca87b6d386d4ea88ee20d")
543 (version (string-append "1.0-" revision "." (string-take commit 7)))
548 (url "https://github.com/antirez/linenoise")
550 (file-name (string-append name "-" version "-checkout"))
553 "1z16qwix8z6a40fskdgxsibkqgdrp4q6ncp4n6hnv4r9iihy2d8r"))))
554 (build-system gnu-build-system)
556 `(#:tests? #f ;No tests are included
557 #:make-flags (list "CC=gcc")
559 (modify-phases %standard-phases
562 (lambda* (#:key outputs #:allow-other-keys)
563 ;; At the moment there is no 'make install' in upstream.
564 (let* ((out (assoc-ref outputs "out")))
565 (install-file "linenoise.h"
566 (string-append out "/include/linenoise"))
567 (install-file "linenoise.c"
568 (string-append out "/include/linenoise"))
570 (home-page "https://github.com/antirez/linenoise")
571 (synopsis "Minimal zero-config readline replacement")
573 "Linenoise is a minimal, zero-config, readline replacement.
574 Its features include:
577 @item Single and multi line editing mode with the usual key bindings
578 @item History handling
580 @item Hints (suggestions at the right of the prompt as you type)
581 @item A subset of VT100 escapes, ANSI.SYS compatible
585 (define-public s-shell
586 (let ((commit "da2e5c20c0c5f477ec3426dc2584889a789b1659")
590 (version (git-version "0.0.0" revision commit))
595 (url "https://github.com/rain-1/s")
597 (file-name (string-append name "-" version "-checkout"))
600 "0qiny71ww5nhzy4mnc8652hn0mlxyb67h333gbdxp4j4qxsi13q4"))))
601 (build-system gnu-build-system)
603 `(("linenoise" ,linenoise)))
606 #:make-flags (list "CC=gcc"
607 (string-append "PREFIX="
608 (assoc-ref %outputs "out")))
610 (modify-phases %standard-phases
611 (add-after 'unpack 'install-directory-fix
612 (lambda* (#:key outputs #:allow-other-keys)
613 (let* ((out (assoc-ref outputs "out"))
614 (bin (string-append out "/bin")))
615 (substitute* "Makefile"
618 (add-after 'install 'manpage
619 (lambda* (#:key outputs #:allow-other-keys)
620 (install-file "s.1" (string-append (assoc-ref outputs "out")
621 "/share/man/man1"))))
623 (lambda* (#:key inputs outputs #:allow-other-keys)
624 ;; At this point linenoise is meant to be included,
625 ;; so we have to really copy it into the working directory
627 (let* ((linenoise (assoc-ref inputs "linenoise"))
628 (noisepath (string-append linenoise "/include/linenoise"))
629 (out (assoc-ref outputs "out")))
630 (copy-recursively noisepath "linenoise")
632 (("/bin/s") (string-append out "/bin/s")))
634 (home-page "https://github.com/rain-1/s")
635 (synopsis "Extremely minimal shell with the simplest syntax possible")
637 "S is a new shell that aims to be extremely simple.
638 S does not implemnt the POSIX shell standard.
639 There are no globs or \"splatting\" where a variable $FOO turns into multiple
640 command line arguments. One token stays one token forever.
641 This is a \"no surprises\" straightforward approach.
643 There are no redirection operators > in the shell language, they are added as
644 extra programs. > is just another unix command, < is essentially cat(1).
645 A @code{andglob} program is also provided along with s.")
655 (uri (string-append "https://connochaetos.org/oksh/oksh-"
659 "0ln9yf6pxngsviqszv8klnnvn8vcpplvj1njdn8xr2y8frkbw8r3"))))
660 (build-system gnu-build-system)
662 `(; The test files are not part of the distributed tarball.
664 (home-page "https://connochaetos.org/oksh")
665 (synopsis "Port of OpenBSD Korn Shell")
667 "Oksh is a port of the OpenBSD Korn Shell.
668 The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
679 (url "https://github.com/dimkr/loksh.git")
681 (file-name (git-file-name name version))
683 (base32 "1d92cf5iadj1vwg0wwksaq1691zaxjrd2y4qygj4sdd25zsahj6p"))))
684 (build-system gnu-build-system)
687 ("ncurses" ,ncurses)))
689 `(("pkg-config" ,pkg-config)))
691 `(#:tests? #f ; no tests included
692 #:make-flags (list "CC=gcc" "HAVE_LIBBSD=1"
693 (string-append "PREFIX="
694 (assoc-ref %outputs "out")))
696 (modify-phases %standard-phases
697 (delete 'configure)))) ; no configure script
698 (home-page "https://github.com/dimkr/loksh")
699 (synopsis "Korn Shell from OpenBSD")
701 "loksh is a Linux port of OpenBSD's @command{ksh}. It is a small,
702 interactive POSIX shell targeted at resource-constrained systems.")
703 ;; The file 'LEGAL' says it is the public domain, and the 2
704 ;; exceptions which are listed are not included in this port.
705 (license public-domain)))
714 (uri (string-append "https://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R"
718 "1x4zjj9259ijpf8jw0nyh1fnr1pbm5fwvylclpvcrlb45xrglf5d"))))
719 (build-system gnu-build-system)
721 `(#:tests? #f ; tests require access to /dev/tty
723 (modify-phases %standard-phases
728 (invoke (which "sh") "Build.sh")))
730 (lambda* (#:key outputs #:allow-other-keys)
731 (let* ((out (assoc-ref outputs "out"))
732 (bin (string-append out "/bin"))
733 (man (string-append out "/share/man/man1")))
734 (install-file "mksh" bin)
735 (with-directory-excursion bin
736 (symlink "mksh" "ksh"))
737 (install-file "mksh.1" man)
739 (home-page "https://www.mirbsd.org/mksh.htm")
740 (synopsis "Korn Shell from MirBSD")
741 (description "mksh is an actively developed free implementation of the
742 Korn Shell programming language and a successor to the Public Domain Korn
747 (define-public oil-shell
753 (uri (string-append "https://www.oilshell.org/download/oil-"
757 "03zc7rhhpl0cybng2i3c33pky1knsnyvn526bn91hg6w4znvn66w"))))
758 (build-system gnu-build-system)
760 '(#:tests? #f ; the tests are not distributed in the tarballs
761 #:strip-binaries? #f ; the binaries cannot be stripped
763 (modify-phases %standard-phases
764 (add-after 'unpack 'patch-compiler-invocation
766 (substitute* "configure"
770 (lambda* (#:key outputs #:allow-other-keys)
771 (let ((out (assoc-ref outputs "out")))
773 ;; The configure script doesn't recognize CONFIG_SHELL.
774 (setenv "CONFIG_SHELL" (which "sh"))
775 (invoke "./configure" (string-append "--prefix=" out)
776 "--with-readline"))))
777 (add-before 'install 'make-destination
779 ;; The build scripts don't create the destination directory.
780 (mkdir-p (string-append (assoc-ref %outputs "out") "/bin")))))))
782 `(("readline" ,readline)))
783 (synopsis "Bash-compatible Unix shell")
784 (description "Oil is a Unix / POSIX shell, compatible with Bash. It
785 implements the Oil language, which is a new shell language to which Bash can be
786 automatically translated. The Oil language is a superset of Bash. It also
787 implements the OSH language, a statically-parseable language based on Bash as it
788 is commonly written.")
789 (home-page "https://www.oilshell.org/")
790 (license (list psfl ; The Oil sources include a patched Python 2 source tree