gnu: bind: Rename variable to 'isc-bind'.
[guix.git] / gnu / packages / sssd.scm
blob2afef03055f569a6996cf923c5bfcfb28109d689
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages sssd)
20   #:use-module ((guix licenses) #:prefix license:)
21   #:use-module (guix packages)
22   #:use-module (guix download)
23   #:use-module (guix utils)
24   #:use-module (guix build-system gnu)
25   #:use-module (gnu packages)
26   #:use-module (gnu packages)
27   #:use-module (gnu packages adns)
28   #:use-module (gnu packages augeas)
29   #:use-module (gnu packages check)
30   #:use-module (gnu packages curl)
31   #:use-module (gnu packages cyrus-sasl)
32   #:use-module (gnu packages databases)
33   #:use-module (gnu packages dns)
34   #:use-module (gnu packages docbook)
35   #:use-module (gnu packages documentation)
36   #:use-module (gnu packages glib)
37   #:use-module (gnu packages gnuzilla)
38   #:use-module (gnu packages libunistring)
39   #:use-module (gnu packages linux)
40   #:use-module (gnu packages kerberos)
41   #:use-module (gnu packages openldap)
42   #:use-module (gnu packages tls)
43   #:use-module (gnu packages pcre)
44   #:use-module (gnu packages popt)
45   #:use-module (gnu packages pkg-config)
46   #:use-module (gnu packages samba)
47   #:use-module (gnu packages selinux)
48   #:use-module (gnu packages web)
49   #:use-module (gnu packages xml))
51 (define-public ding-libs
52   (package
53     (name "ding-libs")
54     (version "0.6.0")
55     (source (origin
56               (method url-fetch)
57               (uri (string-append "https://releases.pagure.org/SSSD/ding-libs/"
58                                   "ding-libs-" version ".tar.gz"))
59               (sha256
60                (base32
61                 "1bczkvq7cblp75kqn6r2d7j5x7brfw6wxirzc6d2rkyb80gj2jkn"))))
62     (build-system gnu-build-system)
63     (home-page "https://pagure.io/SSSD/ding-libs/")
64     (synopsis "Libraries for SSSD")
65     (description
66      "DING-LIBS (DING Is Not Glib) are a set of small, useful libraries that
67 the @dfn{System Security Services Daemon} (SSSD) uses and makes available to
68 other projects.  They include: libdhash, an implementation of a dynamic hash
69 table which will dynamically resize to achieve optimal storage and access time
70 properties; ini_config, a library for parsing and managing @code{INI} files;
71 path_utils, a library to manage UNIX paths and subsets of paths; collection, a
72 generic, hierarchical grouping mechanism for complex data sets; ref_array, a
73 dynamically-growing, reference-counted array; libbasicobjects, a set of
74 fundamental object types for C.")
75     (license license:lgpl3+)))
77 ;; Note: This package installs modules for ldb and nss.  For the former we
78 ;; need to set LDB_MODULES_PATH.  For the latter LD_PRELOAD or LD_LIBRARY_PATH
79 ;; is needed.
80 (define-public sssd
81   (package
82     (name "sssd")
83     (version "1.15.2")
84     (source (origin
85               (method url-fetch)
86               (uri (string-append "http://releases.pagure.org/SSSD/sssd/"
87                                   "sssd-" version ".tar.gz"))
88               (sha256
89                (base32
90                 "0r6j28f7vjb1aw65gkw4nz2l3jy605h7wsr1k815hynp2jrzrmac"))))
91     (build-system gnu-build-system)
92     (arguments
93      `(#:make-flags
94        (list (string-append "DOCBOOK_XSLT="
95                             (assoc-ref %build-inputs "docbook-xsl")
96                             "/xml/xsl/docbook-xsl-"
97                             ,(package-version docbook-xsl)
98                             "/manpages/docbook.xsl")
99              ;; Remove "--postvalid" option, because that requires access to
100              ;; online DTDs.
101              "XMLLINT_FLAGS = --catalogs --nonet --noent --xinclude --noout")
102        #:configure-flags
103        (list "--disable-cifs-idmap-plugin"
104              "--without-nfsv4-idmapd-plugin"
105              "--without-python2-bindings"
106              "--without-python3-bindings"
107              (string-append "--with-plugin-path="
108                             (assoc-ref %outputs "out")
109                             "/lib/sssd")
110              (string-append "--with-krb5-plugin-path="
111                             (assoc-ref %outputs "out")
112                             "/lib/krb5/plugins/libkrb5")
113              (string-append "--with-cifs-plugin-path="
114                             (assoc-ref %outputs "out")
115                             "/lib/cifs-utils")
116              (string-append "--with-init-dir="
117                             (assoc-ref %outputs "out")
118                             "/etc/init.d")
119              (string-append "--with-ldb-lib-dir="
120                             (assoc-ref %outputs "out")
121                             "/lib/ldb/modules/ldb")
122              (string-append "--with-xml-catalog-path="
123                             (assoc-ref %build-inputs "docbook-xml")
124                             "/xml/dtd/docbook/catalog.xml"))
125        #:phases
126        (modify-phases %standard-phases
127          (add-after 'unpack 'disable-failing-test
128            (lambda _
129              (substitute* "src/tests/responder_socket_access-tests.c"
130                (("tcase_add_test\\(tc_utils, resp_str_to_array_test\\);") ""))
131              #t)))))
132     (inputs
133      `(("augeas" ,augeas)
134        ("bind" ,isc-bind "utils")
135        ("c-ares" ,c-ares)
136        ("curl" ,curl)
137        ("cyrus-sasl" ,cyrus-sasl)
138        ("dbus" ,dbus)
139        ("ding-libs" ,ding-libs)
140        ("glib" ,glib)
141        ("gnutls" ,gnutls)
142        ("http-parser" ,http-parser)
143        ("jansson" ,jansson)
144        ("ldb" ,ldb)
145        ("libselinux" ,libselinux)
146        ("libsemanage" ,libsemanage)
147        ("libunistring" ,libunistring)
148        ("linux-pam" ,linux-pam)
149        ("mit-krb5" ,mit-krb5)
150        ("nss" ,nss)
151        ("openldap" ,openldap)
152        ("openssl" ,openssl)
153        ("pcre" ,pcre)
154        ("popt" ,popt)
155        ("samba" ,samba)
156        ("talloc" ,talloc)
157        ("tdb" ,tdb)
158        ("tevent" ,tevent)))
159     (native-inputs
160      `(("check" ,check)
161        ("docbook-xsl" ,docbook-xsl)
162        ("docbook-xml" ,docbook-xml)
163        ("libxslt" ,libxslt)
164        ("pkg-config" ,pkg-config)))
165     (home-page "https://pagure.io/SSSD/sssd/")
166     (synopsis "System security services daemon")
167     (description "SSSD is a system daemon.  Its primary function is to provide
168 access to identity and authentication remote resource through a common
169 framework that can provide caching and offline support to the system.  It
170 provides PAM and NSS modules, and in the future will D-BUS based interfaces
171 for extended user information.  It also provides a better database to store
172 local users as well as extended user data.")
173     (license license:gpl3+)))