gnu: signify: Update to 26.
[guix.git] / gnu / packages / microcom.scm
blob3a1ec1d3cb5763fc9455a278ce108615259eed7f
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages microcom)
20   #:use-module (guix packages)
21   #:use-module (guix licenses)
22   #:use-module (guix git-download)
23   #:use-module (guix download)
24   #:use-module (gnu packages autotools)
25   #:use-module (gnu packages readline)
26   #:use-module (guix build-system gnu))
28 (define-public microcom
29   (package
30     (name "microcom")
31     (version "2016.01.09")
32     (source (origin
33               (method git-fetch)
34               (uri (git-reference
35                     (url "https://git.pengutronix.de/git/tools/microcom.git")
36                     (commit "v2016.01.0")))
37               (file-name (string-append name "-" version "-checkout"))
38               (sha256
39                (base32
40                 "080ci5589bpyy5kcl51csmvpw9zysify189hw6awx69pi3cjnxly"))))
41     (build-system gnu-build-system)
42     (inputs `(("readline" ,readline)))
43     (native-inputs `(("automake" ,automake)
44                      ("autoconf" ,autoconf)))
45     (home-page  "http://git.pengutronix.de/?p=tools/microcom.git")
46     (synopsis "Minimalistic serial line terminal program")
47  (description "Microcom is a minimalistic terminal program for accessing
48 devices via a serial connection.  It features connection via RS232 serial
49 interfaces (including setting of transfer rates) as well as in @code{telnetmode}
50 as specified in rfc2217 and a (Linux specific) CAN mode.")
51     (license gpl2+)))