gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / xnee.scm
blob5cd20cbef185af031f74fc6c37b47d3c08026c5b
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages xnee)
21   #:use-module (guix packages)
22   #:use-module (guix licenses)
23   #:use-module (guix download)
24   #:use-module (guix build-system gnu)
25   #:use-module (gnu packages gtk)
26   #:use-module (gnu packages pkg-config)
27   #:use-module (gnu packages xorg))
29 (define-public xnee
30   (package
31     (name "xnee")
32     (version "3.19")
33     (source (origin
34              (method url-fetch)
35              (uri (string-append "mirror://gnu/xnee/xnee-"
36                                  version ".tar.gz"))
37              (sha256
38               (base32
39                "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
40     (build-system gnu-build-system)
41     (inputs
42      `(("gtk+" ,gtk+-2)
43        ("libx11" ,libx11)
44        ("libxext" ,libxext)
45        ("libxi" ,libxi)
46        ("libxtst" ,libxtst)
47        ("xorgproto" ,xorgproto)))
48     (native-inputs
49       `(("pkg-config" ,pkg-config)))
50     (home-page "https://www.gnu.org/software/xnee/")
51     (synopsis "Record, replay and distribute user actions under X11")
52     (description
53      "GNU Xnee is a program that can record, replay and distribute user
54 actions in X11.  It can be used to automate user interactions for testing or
55 demonstration purposes.")
56     (license gpl3+)))