gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / w3m.scm
blob1ec07675ab9e481c93a6e543b3095a27aa4a4d1a
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
4 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
5 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
23 (define-module (gnu packages w3m)
24   #:use-module ((guix licenses) #:select (x11-style))
25   #:use-module (gnu packages gettext)
26   #:use-module (gnu packages bdw-gc)
27   #:use-module (gnu packages compression)
28   #:use-module (gnu packages gtk)
29   #:use-module (gnu packages ncurses)
30   #:use-module (gnu packages perl)
31   #:use-module (gnu packages pkg-config)
32   #:use-module (gnu packages tls)
33   #:use-module (gnu packages xorg)
34   #:use-module (gnu packages)
35   #:use-module (guix packages)
36   #:use-module (guix git-download)
37   #:use-module (guix build-system gnu))
39 (define-public w3m
40   (package
41     (name "w3m")
42     (version "0.5.3+git20190105")
43     (source (origin
44               (method git-fetch)
45               ;; Debian's fork of w3m is the only one that is still maintained.
46               (uri (git-reference
47                     (url "https://salsa.debian.org/debian/w3m.git")
48                     (commit (string-append "v" version))))
49               (file-name (git-file-name name version))
50               (sha256
51                (base32
52                 "1fbg2p8qh2gvi3g4iz4q6vc0k70pf248r4yndi5lcn2m3mzvjx0i"))))
53     (build-system gnu-build-system)
54     (arguments
55      '(#:tests? #f  ; no check target
56        ;; Use $EDITOR instead of a hard-coded value.
57        #:configure-flags '("--with-editor=")
58        #:phases
59        (modify-phases %standard-phases
60          (add-before 'configure 'fix-perl
61            (lambda _ (substitute* '("scripts/w3mmail.cgi.in"
62                                     "scripts/dirlist.cgi.in")
63                        (("@PERL@") (which "perl")))
64              #t)))))
65     (inputs
66      `(("gdk-pixbuf" ,gdk-pixbuf)
67        ("libgc" ,libgc)
68        ("libx11" ,libx11)
69        ("ncurses" ,ncurses)
70        ("openssl" ,openssl)
71        ("zlib" ,zlib)))
72     (native-inputs
73      `(("gettext" ,gettext-minimal)
74        ("perl" ,perl)
75        ("pkg-config" ,pkg-config)))
76     (home-page "http://w3m.sourceforge.net/")
77     (synopsis "Text-mode web browser")
78     (description
79      "w3m is a text-based web browser as well as a pager like @code{more} or
80 @code{less}.  With w3m you can browse web pages through a terminal emulator
81 window.  Moreover, w3m can be used as a text formatting tool which
82 typesets HTML into plain text.")
83     (license (x11-style "file://doc/README"
84                         "See 'doc/README' in the distribution."))))