gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / poedit.scm
blob0b21a9eea7688d094367eb8ddd6dea7e83753ed7
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages poedit)
20   #:use-module ((guix licenses) #:prefix license:)
21   #:use-module (gnu packages)
22   #:use-module (guix packages)
23   #:use-module (guix git-download)
24   #:use-module (guix utils)
25   #:use-module (guix build-system gnu)
26   #:use-module (gnu packages autotools)
27   #:use-module (gnu packages boost)
28   #:use-module (gnu packages enchant)
29   #:use-module (gnu packages gettext)
30   #:use-module (gnu packages gtk)
31   #:use-module (gnu packages icu4c)
32   #:use-module (gnu packages pkg-config)
33   #:use-module (gnu packages rdf)
34   #:use-module (gnu packages wxwidgets)
35   #:use-module (gnu packages xml))
37 (define-public poedit
38   (package
39     (name "poedit")
40     (version "2.2.1")
41     (source (origin
42               (method git-fetch)
43               (uri (git-reference
44                      (url "https://github.com/vslavik/poedit")
45                      (commit (string-append "v" version "-oss"))))
46               (file-name (git-file-name name version))
47               (sha256
48                (base32
49                 "1fxzmry4b23l90j03jdyvd4jprdpy4xcnhw7xrmmfnlbh2abf9x7"))
50              (modules '((guix build utils)))
51              (snippet
52               '(begin
53                  (delete-file-recursively "deps")
54                  #t))))
55     (build-system gnu-build-system)
56     (arguments
57      `(#:configure-flags
58        (list (string-append "--with-boost-libdir="
59                             (assoc-ref %build-inputs "boost")
60                             "/lib"))))
61     (native-inputs
62      `(("autoconf" ,autoconf)
63        ("automake" ,automake)
64        ("gettext-minimal" ,gettext-minimal)
65        ("pkg-config" ,pkg-config)))
66     (inputs
67      `(("boost" ,boost)
68        ("enchant" ,enchant)
69        ("gtk+" ,gtk+)
70        ("gtkspell3" ,gtkspell3)
71        ("icu4c" ,icu4c)
72        ("lucene++" ,lucene++)
73        ("pugixml" ,pugixml)
74        ("wxwidgets" ,wxwidgets)))
75     (home-page "https://poedit.net/")
76     (synopsis "Gettext catalog editing tool")
77     (description "Poedit is a GUI frontend to the GNU gettext utilities and
78 a catalog editor/source code parser.  It helps with translating applications
79 into other languages.")
80     (license license:expat)))