gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / texi2html-document-encoding.patch
blob1469b67fa6dbaf7c1438e70a96c86abe4a111d58
1 Patch derived from discussion at https://savannah.nongnu.org/bugs/?37503
3 --- texi2html-5.0/texi2html.pl 2010-06-30 17:01:27.000000000 -0500
4 +++ texi2html-5.0/texi2html.pl 2014-07-09 01:17:57.062990582 -0500
5 @@ -2589,7 +2589,12 @@
6 my $state = shift;
8 # FIXME this should be done only once, for @documentencoding
9 - my $encoding = lc(Texi2HTML::Config::get_conf('DOCUMENT_ENCODING'));
10 + my $encoding;
11 + my $input_encoding = Texi2HTML::Config::get_conf('documentencoding');
12 + if (defined($input_encoding))
13 + {
14 + $encoding = lc($input_encoding);
15 + }
16 if (defined($encoding) and $encoding ne '' and exists($Texi2HTML::Config::t2h_encoding_aliases{$encoding}))
18 $encoding = $Texi2HTML::Config::t2h_encoding_aliases{$encoding};
20 Fix failures in test/encodings.
22 --- texi2html-5.0/texi2html.pl 2014-07-09 01:22:06.000000000 -0500
23 +++ texi2html-5.0/texi2html.pl 2014-07-10 23:23:47.182097602 -0500
24 @@ -53,6 +53,7 @@
25 # for translations
26 #use encoding 'utf8';
27 #use utf8;
28 +binmode STDERR, ':encoding(utf8)';
31 # According to