gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / slim-reset.patch
blobeebee6b7b516489861e8f0c17bfceae6dc290e10
1 Do not reset chosen session and maintain the session-choser dialog after a
2 failed login attempt.
4 Patch by E. Bavier
6 --- slim-1.3.6/panel.cpp.orig 1969-12-31 18:00:00.000000000 -0600
7 +++ slim-1.3.6/panel.cpp 2016-10-17 17:00:07.259649063 -0500
8 @@ -260,13 +260,12 @@
11 void Panel::ClearPanel() {
12 - session_name = "";
13 - session_exec = "";
14 Reset();
15 XClearWindow(Dpy, Root);
16 XClearWindow(Dpy, Win);
17 Cursor(SHOW);
18 ShowText();
19 + ShowSession();
20 XFlush(Dpy);
23 @@ -760,9 +760,7 @@
24 pair<string,string> ses = cfg->nextSession();
25 session_name = ses.first;
26 session_exec = ses.second;
27 - if (session_name.size() > 0) {
28 - ShowSession();
29 - }
30 + ShowSession();
33 /* Display session type on the screen */