gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / qt4-ldflags.patch
blob0d6398018ae06896a959b1e40b01d910081445df
1 Explicitly link against libicui18n so that libQtCore.so always finds it.
3 --- qt-everywhere-opensource-src-4.8.6/src/corelib/corelib.pro 2015-04-15 12:01:41.661862663 +0200
4 +++ qt-everywhere-opensource-src-4.8.6/src/corelib/corelib.pro 2015-04-15 12:03:57.954586336 +0200
5 @@ -19,6 +19,13 @@ include(codecs/codecs.pri)
6 include(statemachine/statemachine.pri)
7 include(xml/xml.pri)
9 +# Explicitly link with icui18n, which is dlopened by libQtCore.so.
10 +# We cannot do this by setting LDFLAGS because that then overrides
11 +# other LDFLAGS: <https://bugreports.qt.io/browse/QTBUG-5471>.
12 +# XXX: According to the Nixpkgs recipe, this may be necessary for
13 +# further libraries (cups, gtk-x11-2.0, libgdk-x11-2.0).
14 +LIBS_PRIVATE += -licui18n
16 !qpa:mac|darwin:LIBS_PRIVATE += -framework ApplicationServices
17 qpa:mac {
18 !ios {