gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / psm-repro.patch
blob772801260ef6a4acc6ebdbd98215f2936349023a
1 Remove timestamp to support reproducible builds.
3 --- psm-3.3/Makefile~ 1970-01-01 01:00:00.000000000 +0100
4 +++ psm-3.3/Makefile 2017-10-22 15:32:11.736949002 +0100
5 @@ -326,7 +326,7 @@
6 # file around. Generate it such that the ident command can find it
7 # and strings -a | grep InfiniPath does a reasonable job as well.
8 ${TARGLIB}.so.${MAJOR}.${MINOR}: ${${TARGLIB}-objs}
9 - date +'char psmi_infinipath_revision[] ="$$""Date: %F %R ${rpm_extra_description}InfiniPath $$";' > ${lib_build_dir}/_revision.c
10 + echo 'char psmi_infinipath_revision[] ="$$""Date: 1970-01-01 00:00 ${rpm_extra_description}InfiniPath $$";' > ${lib_build_dir}/_revision.c
11 $(CC) -c $(BASECFLAGS) $(INCLUDES) _revision.c -o _revision.o
12 $(CC) $(LDFLAGS) -o $@ -Wl,-soname=${TARGLIB}.so.${MAJOR} -shared -Wl,--unique='*fastpath*' \
13 ${${TARGLIB}-objs} _revision.o -L$(build_dir)/ipath $(LDLIBS)