gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / mrustc-0.8.0-fix-variable-length-integer-receiving.patch
blob9e76653a077505f10fba05a41a2555dbed8cfdb3
1 https://github.com/thepowersgang/mrustc/issues/109
2 From: Danny Milosavljevic <dannym@scratchpost.org>
3 Date: Fri, 3 Jan 2019 13:00:00 +0100
5 --- mrustc/src/expand/proc_macro.cpp.orig 2019-02-01 14:16:54.208486062 +0100
6 +++ mrustc/src/expand/proc_macro.cpp 2019-02-01 14:17:14.350925705 +0100
7 @@ -977,7 +977,7 @@
8 for(;;)
10 auto b = recv_u8();
11 - v |= static_cast<uint64_t>(b) << ofs;
12 + v |= static_cast<uint64_t>(b & 0x7F) << ofs;
13 if( (b & 0x80) == 0 )
14 break;
15 ofs += 7;