gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / mesa-skip-disk-cache-test.patch
blob190f6b6ee1028cb78073f59b2c76fa7aa5efdc26
1 disk_cache_create() here looks up the users home directory from <pwd.h>
2 which resolves to "/" in the build environment. I could not find an easy
3 way to set the home directory to something else, so we disable this test
4 for now.
6 --- a/src/compiler/glsl/tests/cache_test.c
7 +++ b/src/compiler/glsl/tests/cache_test.c
8 @@ -170,11 +170,6 @@
9 unsetenv("MESA_GLSL_CACHE_DIR");
10 unsetenv("XDG_CACHE_HOME");
12 - cache = disk_cache_create("test", "make_check", 0);
13 - expect_non_null(cache, "disk_cache_create with no environment variables");
15 - disk_cache_destroy(cache);
17 /* Test with XDG_CACHE_HOME set */
18 setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
19 cache = disk_cache_create("test", "make_check", 0);