gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / libreoffice-boost.patch
blobb50664226bea97f81d40a659f2cece8007278151
1 Fix compatibility with newer Boost.
3 Extracted from this upstream commit:
4 https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
6 diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
7 --- a/sfx2/source/appl/shutdownicon.cxx
8 +++ b/sfx2/source/appl/shutdownicon.cxx
9 @@ -144,7 +144,7 @@ bool LoadModule()
10 #endif // ENABLE_QUICKSTART_APPLET
12 assert(!boost::logic::indeterminate(loaded));
13 - return loaded;
14 + return bool(loaded);