gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / libffi-3.2.1-complex-alpha.patch
blobebbc0635a5b420293be65c1e035c485795f77fe6
1 The patch fixes build failure of form:
2 ../src/alpha/osf.S:298:2: error: #error "osf.S out of sync with ffi.h"
3 Upstream fixed the bug in a more invasive way
4 but didn't have releases since 3.2.1.
6 The patch is taken from Gentoo:
7 https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-libs/libffi/files/libffi-3.2.1-complex_alpha.patch
9 --- libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:15.000000000 +0100
10 +++ libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:24.000000000 +0100
11 @@ -279,6 +279,7 @@
12 .gprel32 $load_64 # FFI_TYPE_SINT64
13 .gprel32 $load_none # FFI_TYPE_STRUCT
14 .gprel32 $load_64 # FFI_TYPE_POINTER
15 + .gprel32 $load_none # FFI_TYPE_COMPLEX
17 /* Assert that the table above is in sync with ffi.h. */
19 @@ -294,7 +295,8 @@
20 || FFI_TYPE_SINT64 != 12 \
21 || FFI_TYPE_STRUCT != 13 \
22 || FFI_TYPE_POINTER != 14 \
23 - || FFI_TYPE_LAST != 14
24 + || FFI_TYPE_COMPLEX != 15 \
25 + || FFI_TYPE_LAST != 15
26 #error "osf.S out of sync with ffi.h"
27 #endif