1 The patch fixes build failure of form:
2 ../src/alpha/osf.S:298:2: error: #error "osf.S out of sync with ffi.h"
3 Upstream fixed the bug in a more invasive way
4 but didn't have releases since 3.2.1.
6 The patch is taken from Gentoo:
7 https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-libs/libffi/files/libffi-3.2.1-complex_alpha.patch
9 --- libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:15.000000000 +0100
10 +++ libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:24.000000000 +0100
12 .gprel32 $load_64 # FFI_TYPE_SINT64
13 .gprel32 $load_none # FFI_TYPE_STRUCT
14 .gprel32 $load_64 # FFI_TYPE_POINTER
15 + .gprel32 $load_none # FFI_TYPE_COMPLEX
17 /* Assert that the table above is in sync with ffi.h. */
20 || FFI_TYPE_SINT64 != 12 \
21 || FFI_TYPE_STRUCT != 13 \
22 || FFI_TYPE_POINTER != 14 \
23 - || FFI_TYPE_LAST != 14
24 + || FFI_TYPE_COMPLEX != 15 \
25 + || FFI_TYPE_LAST != 15
26 #error "osf.S out of sync with ffi.h"