gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / kobodeluxe-enemies-pipe-decl.patch
blob05cd884b2b111186306b46399a141f31e60b0599
1 # Authhor: Damyan Ivanov <dmn@debian.org>
2 # Description: rename pipe2 symbol to pipe2_kbdl to avoid clashes with the one
3 # declared in system unistd.h
4 # Debian-Bug: 527705
5 # Upstream-Report: http://www.freelists.org/post/olofsonprojects/kobodeluxe-failing-to-build-in-Debian-enemiesh75-error-const-enemy-kind-pipe2-redeclared-as-different-kind-of-symbol
6 --- a/enemies.h
7 +++ b/enemies.h
8 @@ -72,7 +72,7 @@ extern const enemy_kind bombdeto;
9 extern const enemy_kind cannon;
10 extern const enemy_kind pipe1;
11 extern const enemy_kind core;
12 -extern const enemy_kind pipe2;
13 +extern const enemy_kind pipe2_kbdl;
14 extern const enemy_kind rock;
15 extern const enemy_kind ring;
16 extern const enemy_kind enemy_m1;
17 @@ -430,7 +430,7 @@ inline int _enemy::realize()
19 inline int _enemy::is_pipe()
21 - return ((_state != notuse) && ((ek == &pipe1) || (ek == &pipe2)));
22 + return ((_state != notuse) && ((ek == &pipe1) || (ek == &pipe2_kbdl)));
26 --- a/enemy.cpp
27 +++ b/enemy.cpp
28 @@ -755,10 +755,10 @@ void _enemy::move_core()
30 void _enemy::kill_core()
32 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
33 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
34 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
35 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
36 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
37 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
38 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
39 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
40 enemies.make(&explosion4, CS2PIXEL(x), CS2PIXEL(y));
41 sound.g_base_core_explo(x, y);
42 release();
43 @@ -978,19 +978,19 @@ void _enemy::move_pipe2()
45 p ^= a;
46 if(p & U_MASK)
47 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
48 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
49 if(p & R_MASK)
50 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
51 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
52 if(p & D_MASK)
53 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
54 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
55 if(p & L_MASK)
56 - enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
57 + enemies.make(&pipe2_kbdl, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
58 manage.add_score(10);
59 release();
63 -const enemy_kind pipe2 = {
64 +const enemy_kind pipe2_kbdl = {
66 &_enemy::make_pipe2,
67 &_enemy::move_pipe2,