gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / erlang-man-path.patch
blob68fc9f45b402e7b313a6309a44a752d762df90c2
1 Patch originally from https://sources.debian.net/patches/erlang/1:20.0.1%2Bdfsg-2/man.patch/
2 by Francois-Denis Gonthier <neumann@lostwebsite.net>.
4 Patch description rewritten for Guix.
6 This patch allows access to the man page with the 'erl -man' command
7 (Erlang manual pages are placed to /gnu/store/..erlang../share/man/ hierarchy
8 as other man pages.)
10 --- a/erts/etc/common/erlexec.c
11 +++ b/erts/etc/common/erlexec.c
12 @@ -709,8 +709,10 @@
13 error("-man not supported on Windows");
14 #else
15 argv[i] = "man";
16 - erts_snprintf(tmpStr, sizeof(tmpStr), "%s/man", rootdir);
17 - set_env("MANPATH", tmpStr);
18 + /*
19 + * Conform to erlang-manpages content.
20 + */
21 + putenv(strsave("MANSECT=1:3:5:7"));
22 execvp("man", argv+i);
23 error("Could not execute the 'man' command.");
24 #endif