1 From 40538ad31a71495649d174b0f7be5f7135d0a905 Mon Sep 17 00:00:00 2001
2 From: David Wells <drwells@email.unc.edu>
3 Date: Sat, 2 Feb 2019 10:00:38 -0500
4 Subject: [PATCH] Avoid calling a deprecated MPI function.
6 This was deprecated a long time ago (1996) and is not present in the
7 latest version of openMPI (4.0): see
9 https://www.open-mpi.org/faq/?category=mpi-removed
11 Credit goes to Pratik Nayak for finding this issue.
13 source/base/mpi.cc | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
16 diff --git a/source/base/mpi.cc b/source/base/mpi.cc
17 index bd1f7f9846a..b8cd45e7c26 100644
18 --- a/source/base/mpi.cc
19 +++ b/source/base/mpi.cc
20 @@ -448,7 +448,7 @@ namespace Utilities
21 MPI_Aint displacements[] = {0, offsetof(MinMaxAvg, min_index)};
22 MPI_Datatype types[] = {MPI_DOUBLE, MPI_INT};
24 - ierr = MPI_Type_struct(2, lengths, displacements, types, &type);
25 + ierr = MPI_Type_create_struct(2, lengths, displacements, types, &type);
28 ierr = MPI_Type_commit(&type);