gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / aegis-constness-error.patch
blob2a6c9d2c376361a25c6c6039c10c44395031a639
1 Fixes a fatal constness error with g++ 4.8.2.
2 --- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
3 +++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
4 @@ -182,7 +182,7 @@
6 // Use optimizations in memchr when possible.
7 if (needle_len == 1)
8 - return memchr(haystack, *needle, haystack_len);
9 + return (void *) memchr(haystack, *needle, haystack_len);
11 // Minimizing the worst-case complexity:
12 // Let n = haystack_len, m = needle_len.