gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / patches / 4store-fix-buildsystem.patch
blob383baa94613a6404dd7342ce3325faa976f376db
1 This patch sets a fixed version to avoid needing Git and the .git/ folder.
2 It also removes the creation of "/var/lib/4store", which is not available
3 during the install phase in GNU Guix.
5 Patch by Roel Janssen <roel@gnu.org>
6 *** a/configure.ac Wed Feb 4 19:05:24 2015
7 --- b/configure.ac Wed Mar 23 11:20:38 2016
8 ***************
9 *** 2,13 ****
10 # Process this file with autoconf to produce a configure script.
12 AC_PREREQ([2.50])
13 ! AC_INIT([4store], m4_esyscmd([./version.sh .version]), [http://4store.org/support/], [4store])
14 AC_CONFIG_SRCDIR([src/backend/backend-intl.h])
15 ! AM_INIT_AUTOMAKE([1.7 std-options -Wall])
16 AC_CONFIG_HEADERS(4store-config.h)
18 # Checks for programs.
19 AC_PROG_LIBTOOL
20 AC_PROG_AWK
21 AC_PROG_CC
22 --- 2,14 ----
23 # Process this file with autoconf to produce a configure script.
25 AC_PREREQ([2.50])
26 ! AC_INIT([4store], [1.1.6], [http://4store.org/support/], [4store])
27 AC_CONFIG_SRCDIR([src/backend/backend-intl.h])
28 ! AM_INIT_AUTOMAKE([1.7 std-options foreign -Wall])
29 AC_CONFIG_HEADERS(4store-config.h)
31 # Checks for programs.
32 + AM_PROG_AR
33 AC_PROG_LIBTOOL
34 AC_PROG_AWK
35 AC_PROG_CC
37 *** a/src/utilities/Makefile.am Wed Feb 4 19:05:24 2015
38 --- b/src/utilities/Makefile.am Wed Mar 23 14:05:56 2016
39 ***************
40 *** 13,20 ****
41 noinst_PROGRAMS = lex-file-verify 4s-rid
43 install-data-local:
44 ! mkdir -p $(DESTDIR)@FS_STORE_ROOT@
45 ! chmod 1777 $(DESTDIR)@FS_STORE_ROOT@
47 4s_backend_destroy_SOURCES = backend-destroy.c
48 4s_backend_destroy_LDADD = ../common/lib4sintl.a
49 --- 13,19 ----
50 noinst_PROGRAMS = lex-file-verify 4s-rid
52 install-data-local:
53 ! echo "Please create the following directory: " $(DESTDIR)@FS_STORE_ROOT@
55 4s_backend_destroy_SOURCES = backend-destroy.c
56 4s_backend_destroy_LDADD = ../common/lib4sintl.a