gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / onc-rpc.scm
blob8f66b07527843fc5698160d8c234cb48fbdef31c
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
4 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
22 (define-module (gnu packages onc-rpc)
23   #:use-module (guix licenses)
24   #:use-module (guix packages)
25   #:use-module (guix download)
26   #:use-module (guix git-download)
27   #:use-module (gnu packages)
28   #:use-module (gnu packages autotools)
29   #:use-module (gnu packages gettext)
30   #:use-module (gnu packages kerberos)
31   #:use-module (gnu packages pkg-config)
32   #:use-module (guix build-system gnu))
34 (define-public libtirpc
35   (package
36     (name "libtirpc")
37     (version "1.1.4")
38     (source (origin
39               (method url-fetch)
40               (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
41                                   version "/libtirpc-"
42                                   version ".tar.bz2"))
43               (sha256
44                (base32
45                 "07anqypf7c719x9y683qz65cxllmzlgmlab2hlahrqcj4bq2k99c"))))
46     (build-system gnu-build-system)
47     (arguments
48      `(#:phases
49        (modify-phases %standard-phases
50          (add-after 'unpack 'remote-dangling-symlink
51            (lambda _
52              (substitute* '("man/netconfig.5"
53                             "man/getnetconfig.3t"
54                             "man/getnetpath.3t"
55                             "man/rpc.3t"
56                             "src/getnetconfig.c"
57                             "tirpc/netconfig.h")
58                (("/etc/netconfig") (string-append %output "/etc/netconfig")))
60              ;; Remove the dangling symlinks since it breaks the
61              ;; 'patch-source-shebangs' file tree traversal.
62              (delete-file "INSTALL")
63              #t)))))
64     (inputs `(("mit-krb5" ,mit-krb5)))
65     (home-page "https://sourceforge.net/projects/libtirpc/")
66     (synopsis "Transport-independent Sun/ONC RPC implementation")
67     (description
68      "This package provides a library that implements the Sun/ONC RPC (remote
69 procedure calls) protocol in a transport-independent manner.  It supports both
70 IPv4 and IPv6.  ONC RPC is notably used by the network file system (NFS).")
71     (license bsd-3)))
73 (define-public rpcbind
74   (package
75     (name "rpcbind")
76     (version "0.2.4")
77     (source
78      (origin
79       (method url-fetch)
80       (uri (string-append "mirror://sourceforge/" name "/" name "/"
81                           version "/"
82                           name "-" version ".tar.bz2"))
83       (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
84       (sha256
85        (base32
86         "0rjc867mdacag4yqvs827wqhkh27135rp9asj06ixhf71m9rljh7"))))
87     (build-system gnu-build-system)
88     (arguments
89      `(#:configure-flags
90        `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
91     (inputs
92      `(("libnsl" ,libnsl)
93        ("libtirpc" ,libtirpc)))
94     (native-inputs
95      `(("pkg-config" ,pkg-config)))
96     (home-page "http://rpcbind.sourceforge.net/")
97     (synopsis "Server to convert RPC program numbers into universal addresses")
98     (description
99      "@command{Rpcbind} is a server that converts RPC program numbers into
100 universal addresses.")
101     (license bsd-3)))
104 (define-public libnsl
105   (package
106     (name "libnsl")
107     (version "1.2.0")
108     (source (origin
109               (method git-fetch)
110               (uri (git-reference
111                     (url "https://github.com/thkukuk/libnsl.git")
112                     (commit (string-append "v" version))))
113               (file-name (git-file-name name version))
114               (sha256
115                (base32
116                 "1chzqhcgh0yia9js8mh92cmhyka7rh32ql6b3mgdk26n94dqzs8b"))))
117     (build-system gnu-build-system)
118     (native-inputs
119      `(("autoconf" ,autoconf)
120        ("automake" ,automake)
121        ("gettext" ,gettext-minimal)
122        ("libtool" ,libtool)
123        ("pkg-config" ,pkg-config)))
124     (inputs
125      `(("libtirpc" ,libtirpc)))
126     (synopsis "Public client interface for NIS(YP) and NIS+")
127     (description "Libnsl is the public client interface for the Network
128 Information Service / Yellow Pages (NIS/YP) and NIS+.  It includes IPv6 support.
129 This library was part of glibc < 2.26, but is now distributed separately.")
130     (home-page "https://github.com/thkukuk/libnsl")
131     ;; The package is distributed under the LGPL 2.1. Some files in
132     ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
133     (license lgpl2.1)))