gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / medical.scm
blob6c298707f50cf6f1e96ba576551e88f39bd527dc
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017 Quiliro <quiliro@fsfla.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages medical)
21   #:use-module (guix build-system python)
22   #:use-module (guix download)
23   #:use-module (guix licenses)
24   #:use-module (guix packages)
25   #:use-module (gnu packages databases)
26   #:use-module (gnu packages python-xyz)
27   #:use-module (gnu packages qt))
29 (define-public openmolar-1
30   (package
31    (name "openmolar")
32    (version "1.0.15-gd81f9e5")
33    (source (origin
34              (method url-fetch)
35              (uri (string-append
36                    "https://static.openmolar.com/om1/releases/openmolar-"
37                    version ".tar.gz"))
38              (sha256
39               (base32
40                "1cfdzfbi6wslw7k0dc6ad6xrgs75iwsl91cg73w4myswaqqkfk3z"))))
41    (build-system python-build-system)
42    (arguments
43     `(#:use-setuptools? #f
44       #:phases
45       (modify-phases %standard-phases
46         (add-after 'unpack 'patch-/usr
47           (lambda* (#:key outputs #:allow-other-keys)
48             (substitute* "setup.py"
49               (("/usr") (assoc-ref outputs "out")))
50             #t)))))
51    (inputs
52     `(("python-pyqt+qscintilla" ,python-pyqt+qscintilla)
53       ("python-mysqlclient" ,python-mysqlclient)
54       ("qscintilla" ,qscintilla)))
55    (home-page "https://openmolar.com/om1")
56    (synopsis "Dental practice management software")
57    (description "Openmolar is a dental practice management suite.  Its
58 functionality includes appointments, patient records, treatment planning,
59 billing etc.  It is a full featured, reliable and thoroughly tested
60 application and has been translated into many languages.")
61    (license gpl3+)))