gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / libffcall.scm
blob3a231f30a0903b33dd8d935d328341259ea1c244
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
21 (define-module (gnu packages libffcall)
22   #:use-module ((guix licenses) #:prefix l:)
23   #:use-module (guix packages)
24   #:use-module (guix download)
25   #:use-module (guix build-system gnu))
27 (define-public libffcall
28    (package
29     (name "libffcall")
30     (version "2.1")
31     (source
32      (origin
33        (method url-fetch)
34        (uri (string-append
35              "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
36        (sha256
37         (base32
38          "0iwcad6w78jp84vd6xaz5fwqm84n3cb42bdf5m5cj5xzpa5zp4d0"))))
39     (build-system gnu-build-system)
40     (arguments `(#:parallel-build? #f))
41     (synopsis "Foreign function calls from interpreters")
42     (description
43      "GNU Libffcall is a collection of libraries that can be used to build
44 foreign function call interfaces in embedded interpreters.")
45     (home-page "https://www.gnu.org/software/libffcall/")
46     (license l:gpl2+)))