gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / jose.scm
blob52f1fc80ec901cc1220c78f25e4cd9cf6712757f
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages jose)
20   #:use-module ((guix licenses) #:prefix license:)
21   #:use-module (guix packages)
22   #:use-module (guix download)
23   #:use-module (guix utils)
24   #:use-module (guix build-system gnu)
25   #:use-module (gnu packages pkg-config)
26   #:use-module (gnu packages web)
27   #:use-module (gnu packages compression)
28   #:use-module (gnu packages tls))
30 (define-public jose
31   (package
32     (name "jose")
33     (version "10")
34     (source (origin
35               (method url-fetch)
36               (uri
37                (string-append "https://github.com/latchset/jose/releases/download/v10/jose-"
38                               version ".tar.bz2"))
39               (sha256
40                (base32
41                 "0wndxz3jqxfxnv5396da3kc1say7442m7mwk2dw9ykawagxxr72w"))))
42     (native-inputs `(("pkg-config" ,pkg-config)))
43     (inputs `(("jansson" ,jansson)
44               ("zlib" ,zlib)
45               ("libcrypto" ,openssl)))
46     (build-system gnu-build-system)
47     (home-page "https://github.com/latchset/jose")
48     (synopsis "Object Signing and Encryption")
49     (description "C-language implementation of Javascript Object Signing and
50 Encryption")
51     (license license:asl2.0)))