1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014, 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
6 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
8 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
11 ;;; This file is part of GNU Guix.
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26 (define-module (gnu packages gcc)
27 #:use-module ((guix licenses)
28 #:select (gpl3+ gpl2+ lgpl2.1+ lgpl2.0+ fdl1.3+))
29 #:use-module (gnu packages)
30 #:use-module (gnu packages bootstrap)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages multiprecision)
33 #:use-module (gnu packages texinfo)
34 #:use-module (gnu packages dejagnu)
35 #:use-module (gnu packages documentation)
36 #:use-module (gnu packages xml)
37 #:use-module (gnu packages docbook)
38 #:use-module (gnu packages graphviz)
39 #:use-module (gnu packages elf)
40 #:use-module (gnu packages perl)
41 #:use-module (guix packages)
42 #:use-module (guix download)
43 #:use-module (guix build-system gnu)
44 #:use-module (guix build-system trivial)
45 #:use-module (guix utils)
46 #:use-module (srfi srfi-1)
47 #:use-module (ice-9 regex))
49 (define %gcc-infrastructure
50 ;; Base URL for GCC's infrastructure.
51 "mirror://gcc/infrastructure/")
53 (define (gcc-configure-flags-for-triplet target)
54 "Return a list of additional GCC `configure' flags for TARGET, a GNU triplet.
56 The purpose of this procedure is to translate extended GNU triplets---e.g.,
57 where the OS part is overloaded to denote a specific ABI---into GCC
58 `configure' options. We take extended GNU triplets that glibc recognizes."
59 (cond ((string-match "^mips64el.*gnuabin?64$" target)
60 ;; Triplets recognized by glibc as denoting the N64 ABI; see
61 ;; ports/sysdeps/mips/preconfigure.
64 ((string-match "^arm.*-gnueabihf$" target)
65 '("--with-arch=armv7-a"
70 ((and (string-suffix? "-gnu" target)
71 (not (string-contains target "-linux")))
72 ;; Cross-compilation of libcilkrts in GCC 5.5.0 to GNU/Hurd fails
74 ;; libcilkrts/runtime/os-unix.c:388:2: error: #error "Unknown architecture"
75 ;; Cilk has been removed from GCC 8 anyway.
76 '("--disable-libcilkrts"))
79 ;; TODO: Add `arm.*-gnueabi', etc.
82 (define-public gcc-4.7
83 (let* ((stripped? #t) ;whether to strip the compiler, not the libraries
86 ;; Return the `_FOR_TARGET' variables that are needed when
87 ;; cross-compiling GCC.
88 (let ((target (%current-target-system)))
90 (map (lambda (var tool)
91 (string-append (string-append var "_FOR_TARGET")
93 '("CC" "CXX" "LD" "AR" "NM" "OBJDUMP" "RANLIB" "STRIP")
94 '("gcc" "g++" "ld" "ar" "nm" "objdump" "ranlib" "strip"))
97 (let ((base '(or (assoc-ref outputs "lib")
98 (assoc-ref outputs "out"))))
100 ;; Return the directory that contains lib/libgcc_s.so et al.
101 (if (%current-target-system)
102 `(string-append ,base "/" ,(%current-target-system))
106 ;; This is terrible. Since we have two levels of quasiquotation,
107 ;; we have to do this convoluted thing just so we can insert the
108 ;; contents of (maybe-target-tools).
112 "--enable-languages=c,c++"
116 ;; No pre-compiled libstdc++ headers, to save space.
117 "--disable-libstdcxx-pch"
119 "--with-local-prefix=/no-gcc-local-prefix"
121 ;; With a separate "lib" output, the build system
122 ;; incorrectly guesses GPLUSPLUS_INCLUDE_DIR, so force
123 ;; it. (Don't use a versioned sub-directory, that's
125 ,(string-append "--with-gxx-include-dir="
126 (assoc-ref %outputs "out")
129 ,(let ((libc (assoc-ref %build-inputs "libc")))
131 (string-append "--with-native-system-header-dir=" libc
133 "--without-headers")))
135 ;; Pass the right options for the target triplet.
137 (or (%current-target-system)
138 (nix-system->gnu-triplet (%current-system)))))
139 (gcc-configure-flags-for-triplet triplet))
141 (maybe-target-tools))))))
148 (uri (string-append "mirror://gnu/gcc/gcc-"
149 version "/gcc-" version ".tar.bz2"))
152 "10k2k71kxgay283ylbbhhs51cl55zn2q38vj5pk4k950qdnirrlj"))
153 (patches (search-patches "gcc-4-compile-with-gcc-5.patch"
154 "gcc-fix-texi2pod.patch"))))
155 (build-system gnu-build-system)
157 ;; Separate out the run-time support libraries because all the
158 ;; dynamic-linked objects depend on it.
159 (outputs '("out" ;commands, etc. (60+ MiB)
160 "lib" ;libgcc_s, libgomp, etc. (15+ MiB)
161 "debug")) ;debug symbols of run-time libraries
163 (inputs `(("gmp" ,gmp)
169 ;; GCC < 5 is one of the few packages that doesn't ship .info files.
170 ;; Newer texinfos fail to build the manual, so we use an older one.
171 (native-inputs `(("perl" ,perl) ;for manpages
172 ("texinfo" ,texinfo-5)))
175 `(#:out-of-source? #t
176 #:configure-flags ,(configure-flags)
178 ;; None of the flags below are needed when doing a Canadian cross.
179 ;; TODO: Simplify this.
180 ,(if (%current-target-system)
184 `(let* ((libc (assoc-ref %build-inputs "libc"))
185 (libc-native (or (assoc-ref %build-inputs "libc-native")
188 (list (string-append "LDFLAGS_FOR_TARGET="
190 "-Wl,-dynamic-linker "
192 ,(glibc-dynamic-linker)))
195 ;; Native programs like 'genhooks' also need that right.
196 ,(string-append "LDFLAGS="
197 "-Wl,-rpath=" libc-native "/lib "
198 "-Wl,-dynamic-linker "
199 "-Wl," libc-native ,(glibc-dynamic-linker))
200 ,(string-append "BOOT_CFLAGS=-O2 "
201 ,(if stripped? "-g0" "-g")))))
206 (modify-phases %standard-phases
207 (add-before 'configure 'pre-configure
208 (lambda* (#:key inputs outputs #:allow-other-keys)
209 (let ((libdir ,(libdir))
210 (libc (assoc-ref inputs "libc")))
212 ;; The following is not performed for `--without-headers'
213 ;; cross-compiler builds.
215 ;; Join multi-line definitions of GLIBC_DYNAMIC_LINKER* into a
216 ;; single line, to allow the next step to work properly.
219 (substitute* (find-files "gcc/config"
220 "^(linux|gnu|sysv4)(64|-elf|-eabi)?\\.h$")
221 (("(#define (GLIBC|GNU_USER)_DYNAMIC_LINKER.*)\\\\\n$" _ line)
225 ;; Fix the dynamic linker's file name.
226 (substitute* (find-files "gcc/config"
227 "^(linux|gnu|sysv4)(64|-elf|-eabi)?\\.h$")
228 (("#define (GLIBC|GNU_USER)_DYNAMIC_LINKER([^ \t]*).*$"
230 (format #f "#define ~a_DYNAMIC_LINKER~a \"~a\"~%"
232 (string-append libc ,(glibc-dynamic-linker)))))
234 ;; Tell where to find libstdc++, libc, and `?crt*.o', except
235 ;; `crt{begin,end}.o', which come with GCC.
236 (substitute* (find-files "gcc/config"
238 (("#define GNU_USER_TARGET_LIB_SPEC (.*)$" _ suffix)
239 ;; Help libgcc_s.so be found (see also below.) Always use
240 ;; '-lgcc_s' so that libgcc_s.so is always found by those
241 ;; programs that use 'pthread_cancel' (glibc dlopens
242 ;; libgcc_s.so when pthread_cancel support is needed, but
243 ;; having it in the application's RUNPATH isn't enough; see
244 ;; <http://sourceware.org/ml/libc-help/2013-11/msg00023.html>.)
246 ;; NOTE: The '-lgcc_s' added below needs to be removed in a
247 ;; later phase of %gcc-static. If you change the string
248 ;; below, make sure to update the relevant code in
249 ;; %gcc-static package as needed.
250 (format #f "#define GNU_USER_TARGET_LIB_SPEC \
251 \"-L~a/lib %{!static:-rpath=~a/lib %{!static-libgcc:-rpath=~a/lib -lgcc_s}} \" ~a"
252 libc libc libdir suffix))
253 (("#define GNU_USER_TARGET_STARTFILE_SPEC.*$" line)
254 (format #f "#define STANDARD_STARTFILE_PREFIX_1 \"~a/lib\"
255 #define STANDARD_STARTFILE_PREFIX_2 \"\"
259 ;; The rs6000 (a.k.a. powerpc) config in GCC does not use
260 ;; GNU_USER_* defines. Do the above for this case.
262 "gcc/config/rs6000/sysv4.h"
263 (("#define LIB_LINUX_SPEC (.*)$" _ suffix)
264 (format #f "#define LIB_LINUX_SPEC \
265 \"-L~a/lib %{!static:-rpath=~a/lib %{!static-libgcc:-rpath=~a/lib -lgcc_s}} \" ~a"
266 libc libc libdir suffix))
267 (("#define STARTFILE_LINUX_SPEC.*$" line)
268 (format #f "#define STANDARD_STARTFILE_PREFIX_1 \"~a/lib\"
269 #define STANDARD_STARTFILE_PREFIX_2 \"\"
273 ;; Don't retain a dependency on the build-time sed.
274 (substitute* "fixincludes/fixincl.x"
275 (("static char const sed_cmd_z\\[\\] =.*;")
276 "static char const sed_cmd_z[] = \"sed\";"))
278 ;; Aarch64 support didn't land in GCC until the 4.8 series.
279 (when (file-exists? "gcc/config/aarch64")
280 ;; Force Aarch64 libdir to be /lib and not /lib64
281 (substitute* "gcc/config/aarch64/t-aarch64-linux"
284 (when (file-exists? "libbacktrace")
285 ;; GCC 4.8+ comes with libbacktrace. By default it builds
286 ;; with -Werror, which fails with a -Wcast-qual error in glibc
287 ;; 2.21's stdlib-bsearch.h. Remove -Werror.
288 (substitute* "libbacktrace/configure"
289 (("WARN_FLAGS=(.*)-Werror" _ flags)
290 (string-append "WARN_FLAGS=" flags)))
292 (when (file-exists? "libsanitizer/libbacktrace")
293 ;; Same in libsanitizer's bundled copy (!) found in 4.9+.
294 (substitute* "libsanitizer/libbacktrace/Makefile.in"
298 ;; Add a RUNPATH to libstdc++.so so that it finds libgcc_s.
299 ;; See <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354>
300 ;; and <http://bugs.gnu.org/20358>.
301 (substitute* "libstdc++-v3/src/Makefile.in"
303 "OPT_LDFLAGS = -Wl,-rpath=$(libdir) "))
305 ;; Move libstdc++*-gdb.py to the "lib" output to avoid a
306 ;; circularity between "out" and "lib". (Note:
307 ;; --with-python-dir is useless because it imposes $(prefix) as
308 ;; the parent directory.)
309 (substitute* "libstdc++-v3/python/Makefile.in"
311 (string-append "pythondir = " libdir "/share"
312 "/gcc-$(gcc_version)/python\n")))
314 ;; Avoid another circularity between the outputs: this #define
315 ;; ends up in auto-host.h in the "lib" output, referring to
316 ;; "out". (This variable is used to augment cpp's search path,
317 ;; but there's nothing useful to look for here.)
318 (substitute* "gcc/config.in"
319 (("PREFIX_INCLUDE_DIR")
320 "PREFIX_INCLUDE_DIR_isnt_necessary_here"))
323 (add-after 'configure 'post-configure
325 ;; Don't store configure flags, to avoid retaining references to
326 ;; build-time dependencies---e.g., `--with-ppl=/gnu/store/xxx'.
327 (substitute* "Makefile"
328 (("^TOPLEVEL_CONFIGURE_ARGUMENTS=(.*)$" _ rest)
329 "TOPLEVEL_CONFIGURE_ARGUMENTS=\n"))
333 ;; Use the language-specific variables rather than 'CPATH' because they
334 ;; are equivalent to '-isystem' whereas 'CPATH' is equivalent to '-I'.
335 ;; The intent is to allow headers that are in the search path to be
336 ;; treated as "system headers" (headers exempt from warnings) just like
337 ;; the typical /usr/include headers on an FHS system.
338 (list (search-path-specification
339 (variable "C_INCLUDE_PATH")
340 (files '("include")))
341 (search-path-specification
342 (variable "CPLUS_INCLUDE_PATH")
343 (files '("include")))
344 (search-path-specification
345 (variable "LIBRARY_PATH")
346 (files '("lib" "lib64")))))
348 (properties `((gcc-libc . ,(assoc-ref inputs "libc"))))
349 (synopsis "GNU Compiler Collection")
351 "GCC is the GNU Compiler Collection. It provides compiler front-ends
352 for several languages, including C, C++, Objective-C, Fortran, Java, Ada, and
353 Go. It also includes runtime support libraries for these languages.")
355 (supported-systems (delete "aarch64-linux" %supported-systems))
356 (home-page "https://gcc.gnu.org/")))))
358 (define-public gcc-4.8
359 (package (inherit gcc-4.7)
363 (uri (string-append "mirror://gnu/gcc/gcc-"
364 version "/gcc-" version ".tar.bz2"))
367 "08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
368 (patches (search-patches "gcc-arm-link-spec-fix.patch"
369 "gcc-4.8-libsanitizer-fix.patch"
370 "gcc-asan-missing-include.patch"
371 "gcc-fix-texi2pod.patch"))
372 (modules '((guix build utils)))
373 ;; This is required for building with glibc-2.26.
374 ;; https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81712
379 (substitute* (string-append "libgcc/config/"
380 dir "/linux-unwind.h")
381 (("struct ucontext") "ucontext_t")))
382 '("aarch64" "alpha" "bfin" "i386" "m68k"
383 "pa" "sh" "tilepro" "xtensa"))
385 (supported-systems %supported-systems)
389 ,@(package-inputs gcc-4.7)))))
391 (define-public gcc-4.9
392 (package (inherit gcc-4.8)
396 (uri (string-append "mirror://gnu/gcc/gcc-"
397 version "/gcc-" version ".tar.bz2"))
400 "14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
401 (patches (search-patches "gcc-4.9-libsanitizer-fix.patch"
402 "gcc-4.9-libsanitizer-ustat.patch"
403 "gcc-arm-bug-71399.patch"
404 "gcc-asan-missing-include.patch"
405 "gcc-libvtv-runpath.patch"
406 "gcc-fix-texi2pod.patch"))
407 (modules '((guix build utils)))
408 ;; This is required for building with glibc-2.26.
409 ;; https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81712
414 (substitute* (string-append "libgcc/config/"
415 dir "/linux-unwind.h")
416 (("struct ucontext") "ucontext_t")))
417 '("aarch64" "alpha" "bfin" "i386" "m68k" "nios2"
418 "pa" "sh" "tilepro" "xtensa"))
420 ;; Override inherited texinfo-5 with latest version.
421 (native-inputs `(("perl" ,perl) ;for manpages
422 ("texinfo" ,texinfo)))))
425 ;; Note: GCC >= 5 ships with .info files but 'make install' fails to install
426 ;; them in a VPATH build.
427 (package (inherit gcc-4.9)
431 (uri (string-append "mirror://gnu/gcc/gcc-"
432 version "/gcc-" version ".tar.xz"))
435 "11zd1hgzkli3b2v70qsm2hyqppngd4616qc96lmm9zl2kl9yl32k"))
436 (patches (search-patches "gcc-arm-bug-71399.patch"
437 "gcc-libsanitizer-ustat.patch"
438 "gcc-strmov-store-file-names.patch"
439 "gcc-5.0-libvtv-runpath.patch"
440 "gcc-5-source-date-epoch-1.patch"
441 "gcc-5-source-date-epoch-2.patch"
442 "gcc-fix-texi2pod.patch"))
443 (modules '((guix build utils)))
445 ;; Fix 'libcc1/configure' error when cross-compiling GCC.
446 ;; Without that, 'libcc1/configure' wrongfully determines that
447 ;; '-rdynamic' support is missing because $gcc_cv_objdump is
450 ;; https://gcc.gnu.org/bugzilla/show_bug.cgi?id=67590
451 ;; http://cgit.openembedded.org/openembedded-core/commit/?id=f6e47aa9b12f9ab61530c40e0343f451699d9077
453 (substitute* "libcc1/configure"
454 (("\\$gcc_cv_objdump -T")
455 "$OBJDUMP_FOR_TARGET -T"))
458 `(;; GCC5 needs <isl/band.h> which is removed in later versions.
460 ,@(package-inputs gcc-4.7)))))
468 (uri (string-append "mirror://gnu/gcc/gcc-"
469 version "/gcc-" version ".tar.xz"))
472 "0i89fksfp6wr1xg9l8296aslcymv2idn60ip31wr9s4pwin7kwby"))
473 (patches (search-patches "gcc-strmov-store-file-names.patch"
474 "gcc-6-source-date-epoch-1.patch"
475 "gcc-6-source-date-epoch-2.patch"
476 "gcc-5.0-libvtv-runpath.patch"))))
479 ,@(package-inputs gcc-4.7)))
482 ;; We have to use 'CPATH' for GCC > 5, not 'C_INCLUDE_PATH' & co., due to
483 ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129>.
484 (list (search-path-specification
486 (files '("include")))
487 (search-path-specification
488 (variable "LIBRARY_PATH")
489 (files '("lib" "lib64")))))))
497 (uri (string-append "mirror://gnu/gcc/gcc-"
498 version "/gcc-" version ".tar.xz"))
501 "0lgy170b0pp60j9cczqkmaqyjjb584vfamj4c30swd7k0j6y5pgd"))
502 (patches (search-patches "gcc-strmov-store-file-names.patch"
503 "gcc-5.0-libvtv-runpath.patch"))))
505 "GCC is the GNU Compiler Collection. It provides compiler front-ends
506 for several languages, including C, C++, Objective-C, Fortran, Ada, and Go.
507 It also includes runtime support libraries for these languages.")))
515 (uri (string-append "mirror://gnu/gcc/gcc-"
516 version "/gcc-" version ".tar.xz"))
519 "0b3xv411xhlnjmin2979nxcbnidgvzqdf4nbhix99x60dkzavfk4"))
520 (patches (search-patches "gcc-8-strmov-store-file-names.patch"
521 "gcc-5.0-libvtv-runpath.patch"))))))
529 (uri (string-append "mirror://gnu/gcc/gcc-"
530 version "/gcc-" version ".tar.xz"))
533 "1817nc2bqdc251k0lpc51cimna7v68xjrnvqzvc50q3ax4s6i9kr"))
534 (patches (search-patches "gcc-9-strmov-store-file-names.patch"
535 "gcc-9-asan-fix-limits-include.patch"
536 "gcc-5.0-libvtv-runpath.patch"))))))
538 ;; Note: When changing the default gcc version, update
539 ;; the gcc-toolchain-* definitions and the gfortran definition
541 (define-public gcc gcc-5)
543 (define-public (make-libstdc++ gcc)
544 "Return a libstdc++ package based on GCC. The primary use case is when
545 using compilers other than GCC."
550 `(#:out-of-source? #t
551 #:phases (alist-cons-before
554 (chdir "libstdc++-v3")
557 #:configure-flags `("--disable-libstdcxx-pch"
558 ,(string-append "--with-gxx-include-dir="
559 (assoc-ref %outputs "out")
561 (outputs '("out" "debug"))
564 (propagated-inputs '())
565 (synopsis "GNU C++ standard library")))
567 (define-public libstdc++-4.9
568 (make-libstdc++ gcc-4.9))
570 (define (make-libiberty gcc)
571 "Return a libiberty package based on GCC."
576 `(#:out-of-source? #t
578 (modify-phases %standard-phases
579 (add-before 'configure 'chdir
585 (lambda* (#:key outputs #:allow-other-keys)
586 (let* ((out (assoc-ref outputs "out"))
587 (lib (string-append out "/lib/"))
588 (include (string-append out "/include/")))
591 (copy-file "libiberty.a"
592 (string-append lib "libiberty.a"))
593 (copy-file "../include/libiberty.h"
594 (string-append include "libiberty.h"))
599 (propagated-inputs '())
600 (synopsis "Collection of subroutines used by various GNU programs")))
602 (define-public libiberty
603 (make-libiberty gcc))
605 (define* (custom-gcc gcc name languages
607 (search-paths (package-native-search-paths gcc))
608 #:key (separate-lib-output? #t))
609 "Return a custom version of GCC that supports LANGUAGES. Use SEARCH-PATHS
610 as the 'native-search-paths' field."
611 (package (inherit gcc)
613 (outputs (if separate-lib-output?
614 (package-outputs gcc)
615 (delete "lib" (package-outputs gcc))))
616 (native-search-paths search-paths)
617 (properties (alist-delete 'hidden? (package-properties gcc)))
619 (substitute-keyword-arguments `(#:modules ((guix build gnu-build-system)
624 ,@(package-arguments gcc))
625 ((#:configure-flags flags)
626 `(cons (string-append "--enable-languages="
627 ,(string-join languages ","))
628 (remove (cut string-match "--enable-languages.*" <>)
631 `(modify-phases ,phases
632 (add-after 'install 'remove-broken-or-conflicting-files
633 (lambda* (#:key outputs #:allow-other-keys)
634 (for-each delete-file
635 (find-files (string-append (assoc-ref outputs "out") "/bin")
636 ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))
639 (define %generic-search-paths
640 ;; This is the language-neutral search path for GCC. Entries in $CPATH are
641 ;; not considered "system headers", which means GCC can raise warnings for
642 ;; issues in those headers. 'CPATH' is the only one that works for
643 ;; front-ends not in the C family.
644 (list (search-path-specification
646 (files '("include")))
647 (search-path-specification
648 (variable "LIBRARY_PATH")
649 (files '("lib" "lib64")))))
651 (define-public gfortran-4.8
652 (custom-gcc gcc-4.8 "gfortran" '("fortran")
653 %generic-search-paths))
655 (define-public gfortran-4.9
656 (custom-gcc gcc-4.9 "gfortran" '("fortran")
657 %generic-search-paths))
659 (define-public gfortran-5
660 (custom-gcc gcc-5 "gfortran" '("fortran")
661 %generic-search-paths))
663 (define-public gfortran-6
664 (custom-gcc gcc-6 "gfortran" '("fortran")
665 %generic-search-paths))
667 (define-public gfortran-7
668 (custom-gcc gcc-7 "gfortran" '("fortran")
669 %generic-search-paths))
671 (define-public gfortran-8
672 (custom-gcc gcc-8 "gfortran" '("fortran")
673 %generic-search-paths))
675 (define-public gfortran
676 ;; Note: Update this when GCC changes! We cannot use
677 ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
678 ;; that is not 'eq?' with GFORTRAN-5, and thus 'fold-packages' would
679 ;; report two gfortran@5 that are in fact identical.
682 (define-public gccgo-4.9
683 (custom-gcc gcc-4.9 "gccgo" '("go")
684 %generic-search-paths
685 ;; Suppress the separate "lib" output, because otherwise the
686 ;; "lib" and "out" outputs would refer to each other, creating
687 ;; a cyclic dependency. <http://debbugs.gnu.org/18101>
688 #:separate-lib-output? #f))
690 (define-public gcc-objc-4.8
691 (custom-gcc gcc-4.8 "gcc-objc" '("objc")
692 (list (search-path-specification
693 (variable "OBJC_INCLUDE_PATH")
694 (files '("include")))
695 (search-path-specification
696 (variable "LIBRARY_PATH")
697 (files '("lib" "lib64"))))))
699 (define-public gcc-objc-4.9
700 (custom-gcc gcc-4.9 "gcc-objc" '("objc")
701 (list (search-path-specification
702 (variable "OBJC_INCLUDE_PATH")
703 (files '("include")))
704 (search-path-specification
705 (variable "LIBRARY_PATH")
706 (files '("lib" "lib64"))))))
708 (define-public gcc-objc-5
709 (custom-gcc gcc-5 "gcc-objc" '("objc")
710 (list (search-path-specification
711 (variable "OBJC_INCLUDE_PATH")
712 (files '("include")))
713 (search-path-specification
714 (variable "LIBRARY_PATH")
715 (files '("lib" "lib64"))))))
717 (define-public gcc-objc-6
718 (custom-gcc gcc-6 "gcc-objc" '("objc")
719 (list (search-path-specification
720 (variable "OBJC_INCLUDE_PATH")
721 (files '("include")))
722 (search-path-specification
723 (variable "LIBRARY_PATH")
724 (files '("lib" "lib64"))))))
726 (define-public gcc-objc-7
727 (custom-gcc gcc-7 "gcc-objc" '("objc")
728 (list (search-path-specification
729 (variable "OBJC_INCLUDE_PATH")
730 (files '("include")))
731 (search-path-specification
732 (variable "LIBRARY_PATH")
733 (files '("lib" "lib64"))))))
735 (define-public gcc-objc-8
736 (custom-gcc gcc-8 "gcc-objc" '("objc")
737 (list (search-path-specification
738 (variable "OBJC_INCLUDE_PATH")
739 (files '("include")))
740 (search-path-specification
741 (variable "LIBRARY_PATH")
742 (files '("lib" "lib64"))))))
744 (define-public gcc-objc gcc-objc-5)
746 (define-public gcc-objc++-4.8
747 (custom-gcc gcc-4.8 "gcc-objc++" '("obj-c++")
748 (list (search-path-specification
749 (variable "OBJCPLUS_INCLUDE_PATH")
750 (files '("include")))
751 (search-path-specification
752 (variable "LIBRARY_PATH")
753 (files '("lib" "lib64"))))))
755 (define-public gcc-objc++-4.9
756 (custom-gcc gcc-4.9 "gcc-objc++" '("obj-c++")
757 (list (search-path-specification
758 (variable "OBJCPLUS_INCLUDE_PATH")
759 (files '("include")))
760 (search-path-specification
761 (variable "LIBRARY_PATH")
762 (files '("lib" "lib64"))))))
764 (define-public gcc-objc++-5
765 (custom-gcc gcc-5 "gcc-objc++" '("obj-c++")
766 (list (search-path-specification
767 (variable "OBJCPLUS_INCLUDE_PATH")
768 (files '("include")))
769 (search-path-specification
770 (variable "LIBRARY_PATH")
771 (files '("lib" "lib64"))))))
773 (define-public gcc-objc++-6
774 (custom-gcc gcc-6 "gcc-objc++" '("obj-c++")
775 (list (search-path-specification
776 (variable "OBJCPLUS_INCLUDE_PATH")
777 (files '("include")))
778 (search-path-specification
779 (variable "LIBRARY_PATH")
780 (files '("lib" "lib64"))))))
782 (define-public gcc-objc++-7
783 (custom-gcc gcc-7 "gcc-objc++" '("obj-c++")
784 (list (search-path-specification
785 (variable "OBJCPLUS_INCLUDE_PATH")
786 (files '("include")))
787 (search-path-specification
788 (variable "LIBRARY_PATH")
789 (files '("lib" "lib64"))))))
791 (define-public gcc-objc++-8
792 (custom-gcc gcc-8 "gcc-objc++" '("obj-c++")
793 (list (search-path-specification
794 (variable "OBJCPLUS_INCLUDE_PATH")
795 (files '("include")))
796 (search-path-specification
797 (variable "LIBRARY_PATH")
798 (files '("lib" "lib64"))))))
800 (define-public gcc-objc++ gcc-objc++-5)
802 (define (make-libstdc++-doc gcc)
803 "Return a package with the libstdc++ documentation for GCC."
806 (name "libstdc++-doc")
807 (version (package-version gcc))
808 (synopsis "GNU libstdc++ documentation")
810 (native-inputs `(("doxygen" ,doxygen)
814 ("docbook-xml" ,docbook-xml)
815 ("docbook-xsl" ,docbook-xsl)
816 ("graphviz" ,graphviz))) ;for 'dot', invoked by 'doxygen'
818 (propagated-inputs '())
820 '(#:out-of-source? #t
821 #:tests? #f ;it's just documentation
822 #:phases (modify-phases %standard-phases
823 (add-before 'configure 'chdir
825 (chdir "libstdc++-v3")
827 (add-before 'configure 'set-xsl-directory
828 (lambda* (#:key inputs #:allow-other-keys)
829 (let ((docbook (assoc-ref inputs "docbook-xsl")))
830 (substitute* (find-files "doc"
835 (strip-store-file-name docbook))))
839 ;; XXX: There's also a 'doc-info' target, but it
840 ;; relies on docbook2X, which itself relies on
841 ;; DocBook 4.1.2, which is not really usable
842 ;; (lacks a catalog.xml.)
847 (lambda* (#:key outputs #:allow-other-keys)
848 (let ((out (assoc-ref outputs "out")))
851 "doc-install-man")))))))
852 (properties (alist-delete 'hidden? (package-properties gcc)))))
854 (define-public libstdc++-doc-5
855 (make-libstdc++-doc gcc-5))
857 (define-public libstdc++-doc-9
858 (make-libstdc++-doc gcc-9))
866 (uri (list (string-append
867 "http://isl.gforge.inria.fr/isl-"
870 (string-append %gcc-infrastructure
871 name "-" version ".tar.gz")))
874 "1n4yz9rj24mv226hqbpw210ifvqkn8dgvpnkzf0s0lkq9zrjd5ym"))))
875 (build-system gnu-build-system)
876 (inputs `(("gmp" ,gmp)))
877 (home-page "http://isl.gforge.inria.fr/")
879 "Manipulating sets and relations of integer points \
880 bounded by linear constraints")
882 "isl is a library for manipulating sets and relations of integer points
883 bounded by linear constraints. Supported operations on sets include
884 intersection, union, set difference, emptiness check, convex hull, (integer)
885 affine hull, integer projection, computing the lexicographic minimum using
886 parametric integer programming, coalescing and parametric vertex
887 enumeration. It also includes an ILP solver based on generalized basis
888 reduction, transitive closures on maps (which may encode infinite graphs),
889 dependence analysis and bounds on piecewise step-polynomials.")
892 (define-public isl-0.18
898 (uri (list (string-append "http://isl.gforge.inria.fr/isl-"
900 (string-append %gcc-infrastructure
901 "isl-" version ".tar.gz")))
904 "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))))
906 (define-public isl-0.11
913 (uri (list (string-append
914 "http://isl.gforge.inria.fr/isl-"
917 (string-append %gcc-infrastructure
918 name "-" version ".tar.gz")))
921 "13d9cqa5rzhbjq0xf0b2dyxag7pqa72xj9dhsa03m8ccr1a4npq9"))
922 (patches (search-patches "isl-0.11.1-aarch64-support.patch"))))))
931 (uri (list (string-append
932 "http://www.bastoul.net/cloog/pages/download/count.php3?url=cloog-"
935 (string-append %gcc-infrastructure
936 name "-" version ".tar.gz")))
939 "0a12rwfwp22zd0nlld0xyql11cj390rrq1prw35yjsw8wzfshjhw"))
940 (file-name (string-append name "-" version ".tar.gz"))))
941 (build-system gnu-build-system)
942 (inputs `(("gmp" ,gmp)
944 (arguments '(#:configure-flags '("--with-isl=system")))
945 (home-page "http://www.cloog.org/")
946 (synopsis "Library to generate code for scanning Z-polyhedra")
948 "CLooG is a free software library to generate code for scanning
949 Z-polyhedra. That is, it finds a code (e.g., in C, FORTRAN...) that
950 reaches each integral point of one or more parameterized polyhedra.
951 CLooG has been originally written to solve the code generation problem
952 for optimizing compilers based on the polytope model. Nevertheless it
953 is used now in various area e.g., to build control automata for
954 high-level synthesis or to find the best polynomial approximation of a
955 function. CLooG may help in any situation where scanning polyhedra
956 matters. While the user has full control on generated code quality,
957 CLooG is designed to avoid control overhead and to produce a very
961 (define-public gnu-c-manual
963 (name "gnu-c-manual")
967 (uri (string-append "mirror://gnu/gnu-c-manual/gnu-c-manual-"
971 "1sfsj9256w18qzylgag2h5h377aq8in8929svblfnj9svfriqcys"))))
972 (build-system gnu-build-system)
973 (native-inputs `(("texinfo" ,texinfo)))
975 '(#:phases (modify-phases %standard-phases
982 "gnu-c-manual.html")))
984 (lambda* (#:key outputs #:allow-other-keys)
985 (let* ((out (assoc-ref outputs "out"))
986 (info (string-append out "/share/info"))
988 out "/share/doc/gnu-c-manual")))
992 (for-each (lambda (file)
994 (string-append info "/"
996 (find-files "." "\\.info(-[0-9])?$"))
997 (for-each (lambda (file)
999 (string-append html "/"
1001 (find-files "." "\\.html$"))
1003 (synopsis "Reference manual for the C programming language")
1005 "This is a reference manual for the C programming language, as
1006 implemented by the GNU C Compiler (gcc). As a reference, it is not intended
1007 to be a tutorial of the language. Rather, it outlines all of the constructs
1008 of the language. Library functions are not included.")
1009 (home-page "https://www.gnu.org/software/gnu-c-manual/")