gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / freeipmi.scm
blob5f1931e7fec5ff07b8a15fe0350b178eac3fef46
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
21 (define-module (gnu packages freeipmi)
22   #:use-module (guix packages)
23   #:use-module (guix licenses)
24   #:use-module (guix download)
25   #:use-module (guix build-system gnu)
26   #:use-module (gnu packages gnupg))
28 (define-public freeipmi
29   (package
30     (name "freeipmi")
31     (version "1.6.3")
32     (source (origin
33              (method url-fetch)
34              (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
35                                  version ".tar.gz"))
36              (sha256
37               (base32
38                "1sg12ycig2g5yv9l3vx25wsjmz7ybnrsvji0vs51yjmclwsygm5a"))))
39     (build-system gnu-build-system)
40     (inputs
41      `(("libgcrypt" ,libgcrypt)))
42     (home-page "https://www.gnu.org/software/freeipmi/")
43     (synopsis "Platform management, including sensor and power monitoring")
44     (description
45      "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
46 in accordance with the IPMI v1.5/2.0 specification.  These programs provide a
47 set of interfaces for platform management.  Common functionality includes
48 sensor monitoring, system event monitoring, power control and
49 serial-over-LAN.")
50     (license gpl3+)))