1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;; This file is part of GNU Guix.
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages flex)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages m4)
27 #:use-module (gnu packages man)
28 #:use-module (gnu packages bison)
29 #:use-module (gnu packages code)
30 #:use-module (srfi srfi-1))
39 "https://github.com/westes/flex"
40 "/releases/download/v" version "/"
41 "flex-" version ".tar.gz"))
44 "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
45 (build-system gnu-build-system)
47 (let ((bison-for-tests
50 ;; Disable tests, since they require flex.
51 (arguments '(#:tests? #f))
52 (inputs (alist-delete "flex" (package-inputs bison))))))
53 `(("bison" ,bison-for-tests)
55 ;; m4 is not present in PATH when cross-building
57 `(("help2man" ,help2man)
59 (propagated-inputs `(("m4" ,m4)))
60 (home-page "https://github.com/westes/flex")
61 (synopsis "Fast lexical analyser generator")
63 "Flex is a tool for generating scanners. A scanner, sometimes
64 called a tokenizer, is a program which recognizes lexical patterns in
65 text. The flex program reads user-specified input files, or its standard
66 input if no file names are given, for a description of a scanner to
67 generate. The description is in the form of pairs of regular expressions
68 and C code, called rules. Flex generates a C source file named,
69 \"lex.yy.c\", which defines the function yylex(). The file \"lex.yy.c\"
70 can be compiled and linked to produce an executable. When the executable
71 is run, it analyzes its input for occurrences of text matching the
72 regular expressions for each rule. Whenever it finds a match, it
73 executes the corresponding C code.")
74 (license (non-copyleft "file://COPYING"
75 "See COPYING in the distribution."))))
77 (define-public flex-2.6.1
83 (uri (string-append "https://github.com/westes/flex"
84 "/releases/download/v" version "/"
85 "flex-" version ".tar.xz"))
88 "0gqhk4vkwy4gl9xbpgkljph8c0a5kpijz6wd0p5r9q202qn42yic"))))))