gnu: python-babel: Update to 2.7.0.
[guix.git] / gnu / packages / dunst.scm
blob31b7f58758b8888e1d05fd98cc8ba2992f30975f
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages dunst)
21   #:use-module (guix packages)
22   #:use-module (guix download)
23   #:use-module (guix build-system gnu)
24   #:use-module ((guix licenses) #:prefix license:)
25   #:use-module (gnu packages base)
26   #:use-module (gnu packages freedesktop)
27   #:use-module (gnu packages glib)
28   #:use-module (gnu packages gtk)
29   #:use-module (gnu packages perl)
30   #:use-module (gnu packages pkg-config)
31   #:use-module (gnu packages xorg))
33 (define-public dunst
34   (package
35     (name "dunst")
36     (version "1.3.2")
37     (source (origin
38               (method url-fetch)
39               (uri (string-append
40                     "https://github.com/dunst-project/dunst/archive/v"
41                     version ".tar.gz"))
42               (file-name (string-append name "-" version ".tar.gz"))
43               (sha256
44                (base32
45                 "12nj8qw3y3nl8sm24wizy2a7k06v1p88bnz1xr9l39h527xyidma"))))
46     (build-system gnu-build-system)
47     (arguments
48      '(#:tests? #f                      ; no check target
49        #:make-flags (list "CC=gcc"
50                           (string-append "PREFIX=" %output)
51                           ;; Otherwise it tries to install service file
52                           ;; to "dbus" store directory.
53                           (string-append "SERVICEDIR_DBUS=" %output
54                                          "/share/dbus-1/services"))
55        #:phases (modify-phases %standard-phases
56                   (delete 'configure))))
57     (native-inputs
58      `(("pkg-config" ,pkg-config)
59        ("perl" ,perl)                   ; for pod2man
60        ("which" ,which)))
61     (inputs
62      `(("dbus" ,dbus)
63        ("gdk-pixbuf" ,gdk-pixbuf+svg)   ; for svg support
64        ("glib" ,glib)
65        ("cairo" ,cairo)
66        ("pango" ,pango)
67        ("libx11" ,libx11)
68        ("libxscrnsaver" ,libxscrnsaver)
69        ("libxinerama" ,libxinerama)
70        ("libxrandr" ,libxrandr)
71        ("libxdg-basedir" ,libxdg-basedir)))
72     (home-page "https://dunst-project.org/")
73     (synopsis "Customizable and lightweight notification daemon")
74     (description
75      "Dunst is a highly configurable and minimalistic notification daemon.
76 It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
77 started automatically on the first call via D-Bus.")
78     (license license:bsd-3)))