1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
6 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; This file is part of GNU Guix.
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23 (define-module (gnu packages sync)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix build-system cmake)
26 #:use-module (guix build-system go)
27 #:use-module (guix build-system meson)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module (guix packages)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages acl)
33 #:use-module (gnu packages check)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages curl)
36 #:use-module (gnu packages golang)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages lua)
39 #:use-module (gnu packages perl)
40 #:use-module (gnu packages python-xyz)
41 #:use-module (gnu packages pkg-config)
42 #:use-module (gnu packages qt)
43 #:use-module (gnu packages rsync)
44 #:use-module (gnu packages selinux)
45 #:use-module (gnu packages sqlite)
46 #:use-module (gnu packages tls))
48 (define-public owncloud-client
50 (name "owncloud-client")
51 (version "2.5.3.11470")
55 (uri (string-append "https://download.owncloud.com/desktop/stable/"
56 "owncloudclient-" version ".tar.xz"))
58 (base32 "0cznis8qadsnlgm046lxn8vmbxli6zp4b8nk93n53mkfxlcw355n"))
59 (patches (search-patches "owncloud-disable-updatecheck.patch"))
60 (modules '((guix build utils)))
63 ;; libcrashreporter-qt has its own bundled dependencies
64 (delete-file-recursively "src/3rdparty/libcrashreporter-qt")
65 (delete-file-recursively "src/3rdparty/sqlite3")
66 ;; qprogessindicator, qlockedfile, qtokenizer and
67 ;; qtsingleapplication have not yet been packaged, but all are
68 ;; explicitly used from the 3rdparty folder during build.
69 ;; We can also remove the macgoodies folder
70 (delete-file-recursively "src/3rdparty/qtmacgoodies")
72 (build-system cmake-build-system)
75 (modify-phases %standard-phases
76 (add-after 'unpack 'delete-failing-tests
77 ;; "Could not create autostart folder"
79 (substitute* "test/CMakeLists.txt"
80 (("owncloud_add_test\\(Utility \"\"\\)" test)
81 (string-append "#" test)))
83 (add-after 'unpack 'dont-embed-store-path
85 (substitute* "src/common/utility_unix.cpp"
86 (("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
88 (delete 'patch-dot-desktop-files))
89 #:configure-flags '("-DUNIT_TESTING=ON"
90 ;; build without qtwebkit, which causes the
91 ;; package to FTBFS while looking for QWebView.
92 "-DNO_SHIBBOLETH=1")))
96 ("pkg-config" ,pkg-config)
97 ("qtlinguist" ,qttools)))
100 ("qtkeychain" ,qtkeychain)
103 (home-page "https://owncloud.org")
104 (synopsis "Folder synchronization with an ownCloud server")
105 (description "The ownCloudSync system lets you always have your latest
106 files wherever you are. Just specify one or more folders on the local machine
107 to and a server to synchronize to. You can configure more computers to
108 synchronize to the same server and any change to the files on one computer will
109 silently and reliably flow across to every other.")
110 (license license:gpl2+)))
112 (define-public qsyncthingtray
114 (name "qsyncthingtray")
120 (url "https://github.com/sieren/QSyncthingTray")
122 (file-name (git-file-name name version))
125 "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
126 (build-system cmake-build-system)
128 `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
130 (modify-phases %standard-phases
131 ;; The program is meant to be run from the git repo or source tarball.
133 (lambda* (#:key outputs #:allow-other-keys)
134 (let* ((out (assoc-ref outputs "out"))
135 (bin (string-append out "/bin")))
136 (install-file "QSyncthingTray" bin)
137 (mkdir-p (string-append out "/share/pixmaps"))
138 (copy-file "../source/resources/images/Icon1024.png"
140 out "/share/pixmaps/QSyncthingTray.png"))
142 #:tests? #f)) ; no test target
145 ("qtwebkit" ,qtwebkit)))
146 (home-page "https://github.com/sieren/QSyncthingTray")
147 (synopsis "Traybar Application for Syncthing")
149 "A traybar application for syncthing.
151 @item Shows number of connections at a glance.
152 @item Traffic statistics about incoming, outgoing and total throughput.
153 @item Launches Syncthing and Syncthing-iNotifier if specified.
154 @item Quickly pause Syncthing with one click.
155 @item Last Synced Files - Quickly see the recently synchronised files and open
157 @item Quick Access to all shared folders.
158 @item Presents Syncthing UI in a separate view instead of using the browser.
159 @item Supports authenticated HTTPS connections.
160 @item Uses System Notifications about current connection status.
161 @item Toggle for monochrome icon.
163 (license license:lgpl3+)))
165 (define-public lsyncd
173 (url "https://github.com/axkibe/lsyncd.git")
174 (commit (string-append "release-" version))))
175 (file-name (git-file-name name version))
177 (base32 "1q2ixp52r96ckghgmxdbms6xrq8dbziimp8gmgzqfq4lk1v1w80y"))))
178 (build-system cmake-build-system)
180 `(;; The "tests" target is broken and assumes that tests are run in the
183 #:test-target "tests"
185 (modify-phases %standard-phases
186 ;; No install target.
188 (lambda* (#:key outputs #:allow-other-keys)
189 (let* ((out (assoc-ref outputs "out"))
190 (bin (string-append out "/bin"))
191 (man (string-append out "/share/man/man1")))
192 (install-file "lsyncd" bin)
193 (install-file "../source/doc/manpage/lsyncd.1" man)
197 (home-page "https://github.com/axkibe/lsyncd")
198 (synopsis "Synchronize local directories with remote targets")
199 (description "Lsyncd watches a local directory trees event monitor
200 interface (inotify or fsevents). It aggregates and combines events for a few
201 seconds and then spawns one (or more) process(es) to synchronize the changes.
202 By default this is rsync, which must be installed on all source and target
203 machines. Lsyncd is thus a light-weight live mirror solution that is
204 comparatively easy to install not requiring new file systems or block devices
205 and does not hamper local file system performance.")
206 (license license:gpl2+)))
208 (define-public casync
212 (home-page "https://github.com/systemd/casync/")
217 (commit (string-append "v" version))))
220 "0znkp3fcksrykcsv06y2mjvf2lbwmin25snmvfa8i5qfm3f4rm88"))
221 (file-name (string-append name "-" version "-checkout"))
222 (patches (search-patches "casync-renameat2-declaration.patch"))))
223 (build-system meson-build-system)
225 `(("pkg-config" ,pkg-config)
226 ("python-sphinx" ,python-sphinx)
227 ("rsync" ,rsync))) ;for tests
229 `(("xz" ,xz) ;for liblzma
233 ("libselinux" ,libselinux)
237 (synopsis "File synchronization and backup system")
239 "casync is a @dfn{content-addressable data synchronizer} that can be used
240 as the basis of a backup system. It is:
243 @item A combination of the rsync algorithm and content-addressable storage;
244 @item An efficient way to store and retrieve multiple related versions of
245 large file systems or directory trees;
246 @item An efficient way to deliver and update OS, VM, IoT and container images
247 over the Internet in an HTTP and CDN friendly way;
248 @item An efficient backup system.
250 (license license:lgpl2.1+)))
252 (define-public rclone
259 (url "https://github.com/ncw/rclone.git")
260 (commit (string-append "v" version))))
261 (file-name (git-file-name name version))
264 "1nxwjr9jly6wh1ixr6a7zhlg4b3298v940040fsm0n3lcljd37zx"))))
265 ;; FIXME: Rclone bundles some libraries Guix already provides. Need to
267 (build-system go-build-system)
269 '(#:import-path "github.com/ncw/rclone"
270 #:install-source? #f))
271 (synopsis "@code{rsync} for cloud storage")
272 (description "@code{Rclone} is a command line program to sync files and
273 directories to and from different cloud storage providers.
277 @item MD5/SHA1 hashes checked at all times for file integrity
278 @item Timestamps preserved on files
279 @item Partial syncs supported on a whole file basis
280 @item Copy mode to just copy new/changed files
281 @item Sync (one way) mode to make a directory identical
282 @item Check mode to check for file hash equality
283 @item Can sync to and from network, e.g., two different cloud accounts
284 @item Optional encryption (Crypt)
285 @item Optional cache (Cache)
286 @item Optional FUSE mount (rclone mount)
288 (home-page "https://rclone.org/")
289 (license license:expat)))