1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages perl6)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix download)
22 #:use-module (guix git-download)
23 #:use-module (guix packages)
24 #:use-module (guix build-system perl)
25 #:use-module (guix build-system rakudo)
26 #:use-module (gnu packages bdw-gc)
27 #:use-module (gnu packages libevent)
28 #:use-module (gnu packages libffi)
29 #:use-module (gnu packages multiprecision)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages tls))
40 (uri (string-append "https://moarvm.org/releases/MoarVM-"
44 "017w1zvr6yl0cgjfc1b3ddlc6vjw9q8p7alw1vvsckw95190xc14"))
45 (modules '((guix build utils)))
48 ;(delete-file-recursively "3rdparty/dynasm") ; JIT
49 (delete-file-recursively "3rdparty/dyncall")
50 (delete-file-recursively "3rdparty/freebsd")
51 (delete-file-recursively "3rdparty/libatomicops")
52 (delete-file-recursively "3rdparty/libuv")
53 (delete-file-recursively "3rdparty/libtommath")
54 (delete-file-recursively "3rdparty/msinttypes")
56 (build-system perl-build-system)
59 (modify-phases %standard-phases
61 (lambda* (#:key inputs outputs #:allow-other-keys)
62 (let ((out (assoc-ref outputs "out"))
63 (pkg-config (assoc-ref inputs "pkg-config")))
64 (setenv "LDFLAGS" (string-append "-Wl,-rpath=" out "/lib"))
65 (invoke "perl" "Configure.pl"
67 "--pkgconfig" (string-append pkg-config "/bin/pkg-config")
72 (home-page "https://moarvm.org/")
73 ;; These should be inputs but moar.h can't find them when building rakudo
75 `(("libatomic-ops" ,libatomic-ops)
76 ("libtommath" ,libtommath-1.0)
79 `(("libffi" ,libffi)))
81 `(("pkg-config" ,pkg-config)))
82 (synopsis "VM for NQP And Rakudo Perl 6")
84 "Short for \"Metamodel On A Runtime\", MoarVM is a modern virtual machine
85 built for the Rakudo Perl 6 compiler and the NQP Compiler Toolchain. Highlights
89 @item Great Unicode support, with strings represented at grapheme level
90 @item Dynamic analysis of running code to identify hot functions and loops, and
91 perform a range of optimizations, including type specialization and inlining
92 @item Support for threads, a range of concurrency control constructs, and
93 asynchronous sockets, timers, processes, and more
94 @item Generational, parallel, garbage collection
95 @item Support for numerous language features, including first class functions,
96 exceptions, continuations, runtime loading of code, big integers and interfacing
97 with native libraries.
99 (license license:artistic2.0)))
108 (uri (string-append "https://rakudo.perl6.org/downloads/nqp/nqp-"
112 "183zhll13fx416s3hkg4bkvib77kyr857h0nydgrl643fpacxp83"))
113 (modules '((guix build utils)))
116 (delete-file-recursively "3rdparty") #t))))
117 (build-system perl-build-system)
120 (modify-phases %standard-phases
121 (add-after 'patch-source-shebangs 'patch-more-shebangs
123 (substitute* '("tools/build/install-jvm-runner.pl.in"
124 "tools/build/gen-js-cross-runner.pl"
125 "tools/build/gen-js-runner.pl"
126 "tools/build/install-js-runner.pl"
127 "tools/build/install-moar-runner.pl"
128 "tools/build/gen-moar-runner.pl"
129 "t/nqp/111-spawnprocasync.t"
130 "t/nqp/113-run-command.t")
131 (("/bin/sh") (which "sh")))
133 (add-after 'unpack 'patch-source-date
135 (substitute* "tools/build/gen-version.pl"
136 (("gmtime") "gmtime(0)"))
138 (add-after 'unpack 'remove-failing-test
139 ;; One subtest fails for unknown reasons
141 (delete-file "t/nqp/019-file-ops.t")
144 (lambda* (#:key inputs outputs #:allow-other-keys)
145 (let ((out (assoc-ref outputs "out"))
146 (moar (assoc-ref inputs "moarvm")))
147 (invoke "perl" "Configure.pl"
149 "--with-moar" (string-append moar "/bin/moar")
150 "--prefix" out)))))))
152 `(("moarvm" ,moarvm)))
153 (home-page "https://github.com/perl6/nqp")
154 (synopsis "Not Quite Perl")
155 (description "This is \"Not Quite Perl\" -- a lightweight Perl 6-like
156 environment for virtual machines. The key feature of NQP is that it's designed
157 to be a very small environment (as compared with, say, perl6 or Rakudo) and is
158 focused on being a high-level way to create compilers and libraries for virtual
159 machines like MoarVM, the JVM, and others.
161 Unlike a full-fledged implementation of Perl 6, NQP strives to have as small a
162 runtime footprint as it can, while still providing a Perl 6 object model and
163 regular expression engine for the virtual machine.")
164 (license license:artistic2.0)))
166 (define-public rakudo
169 (version "2019.03.1")
173 (uri (string-append "https://rakudo.perl6.org/downloads/rakudo/rakudo-"
177 "1nllf69v8xr6v3kkj7pmryg11n5m3ajfkr7j72pvhrgnjy8lv3r1"))))
178 (build-system perl-build-system)
181 (modify-phases %standard-phases
182 (add-after 'unpack 'patch-source-date
184 (substitute* "tools/build/gen-version.pl"
185 (("gmtime") "gmtime(0)"))
187 (add-after 'patch-source-shebangs 'patch-more-shebangs
189 (substitute* '("tools/build/create-js-runner.pl"
190 "tools/build/create-moar-runner.p6"
191 "tools/build/create-jvm-runner.pl"
193 (("/bin/sh") (which "sh")))
196 (lambda* (#:key inputs outputs #:allow-other-keys)
197 (let ((out (assoc-ref outputs "out"))
198 (nqp (assoc-ref inputs "nqp")))
199 (invoke "perl" "./Configure.pl"
201 "--with-nqp" (string-append nqp "/bin/nqp")
203 ;; This is the recommended tool for distro maintainers to install perl6
204 ;; modules systemwide. See: https://github.com/ugexe/zef/issues/117
205 (add-after 'install 'install-dist-tool
206 (lambda* (#:key outputs #:allow-other-keys)
207 (let* ((out (assoc-ref outputs "out"))
208 (dest (string-append out "/share/perl6/tools")))
209 (install-file "tools/install-dist.p6" dest)
210 (substitute* (string-append dest "/install-dist.p6")
211 (("/usr/bin/env perl6")
212 (string-append out "/bin/perl6"))))
217 ("openssl" ,openssl)))
218 (home-page "https://rakudo.org/")
220 (list (search-path-specification
221 (variable "PERL6LIB")
223 (files '("share/perl6/lib"
224 "share/perl6/site/lib"
225 "share/perl6/vendor/lib")))))
226 (synopsis "Perl 6 Compiler")
227 (description "Rakudo Perl is a compiler that implements the Perl 6
228 specification and runs on top of several virtual machines.")
229 (license license:artistic2.0)))
231 (define-public perl6-grammar-debugger
232 ;; Last commit was September 2017
233 (let ((commit "0375008027c8caa216bd869476ce59ae09b2a702")
236 (name "perl6-grammar-debugger")
237 (version (git-version "1.0.1" revision commit))
242 (url "https://github.com/jnthn/grammar-debugger")
244 (file-name (git-file-name name version))
247 "0y826z3m276n7ia810hgcb3div67nxmx125m2fzlc16994zd5vm5"))))
248 (build-system rakudo-build-system)
250 `(("perl6-terminal-ansicolor" ,perl6-terminal-ansicolor)))
251 (home-page "https://github.com/jnthn/grammar-debugger")
252 (synopsis "Simple tracing and debugging support for Perl 6 grammars")
253 (description "This module provides a simple debugger for grammars. Just
254 @code{use} it: use @code{Grammar::Debugger;} and any grammar in the lexical
255 scope of the use statement will automatically have debugging enabled. The
256 debugger will break execution when you first enter the grammar, and provide a
258 (license license:artistic2.0))))
260 (define-public perl6-grammar-profiler-simple
261 ;; Last commit was June 2017
262 (let ((commit "c0aca5fab323b2974821dabd6b89330c609e0b7d")
265 (name "perl6-grammar-profiler-simple")
266 (version (git-version "0.02" revision commit))
271 (url "https://github.com/perlpilot/Grammar-Profiler-Simple.git")
273 (file-name (git-file-name name version))
276 "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
277 (build-system rakudo-build-system)
278 (arguments '(#:with-zef? #f))
279 (home-page "https://github.com/perlpilot/Grammar-Profiler-Simple")
280 (synopsis "Simple rule profiling for Perl 6 grammars")
281 (description "This module provides a simple profiler for Perl 6 grammars.
282 To enable profiling simply add use @code{Grammar::Profiler::Simple;} to your
283 code. Any grammar in the lexical scope of the use statement will automatically
284 have profiling information collected when the grammar is used.")
285 (license license:artistic2.0))))
287 (define-public perl6-json
295 (url "https://github.com/moritz/json")
296 ;; The commit where 1.0 was "tagged"
297 (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
298 (file-name (git-file-name name version))
301 "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
302 (build-system rakudo-build-system)
303 (arguments '(#:with-zef? #f))
304 (home-page "https://github.com/moritz/json")
305 (synopsis "A minimal JSON (de)serializer")
306 (description "This module is a simple Perl 6 module for serializing and
307 deserializing JSON.")
308 (license license:artistic2.0)))
310 (define-public perl6-json-class
312 (name "perl6-json-class")
318 (url "https://github.com/jonathanstowe/JSON-Class.git")
319 (commit (string-append "v" version))))
320 (file-name (git-file-name name version))
323 "1zyzajc57j3m8q0nr72h9pw4w2nx92rafywlvysgphc5q9sb8np2"))))
324 (build-system rakudo-build-system)
326 `(("perl6-json-marshal" ,perl6-json-marshal)
327 ("perl6-json-unmarshal" ,perl6-json-unmarshal)))
329 `(("perl6-json-fast" ,perl6-json-fast)))
330 (home-page "https://github.com/jonathanstowe/JSON-Class")
331 (synopsis "Provide simple serialisation/deserialisation of objects to/from JSON")
332 (description "This is a simple role that provides methods to instantiate a
333 class from a JSON string that (hopefully,) represents it, and to serialise an
334 object of the class to a JSON string. The JSON created from an instance
335 should round trip to a new instance with the same values for the public
336 attributes. Private attributes (that is ones without accessors,) will be
337 ignored for both serialisation and de-serialisation. The exact behaviour
338 depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal}
340 (license license:artistic2.0)))
342 (define-public perl6-json-fast
344 (name "perl6-json-fast")
350 (url "https://github.com/timo/json_fast.git")
352 (file-name (git-file-name name version))
355 "1fif081gdxdnja14vkj523p9dyzdcdj81lmjv9fvfazvpagb6dg2"))))
356 (build-system rakudo-build-system)
357 (arguments '(#:with-zef? #f))
358 (home-page "https://github.com/timo/json_fast")
359 (synopsis "Perl6 json parser")
360 (description "A naive imperative json parser in pure perl6 (but with direct
361 access to @code{nqp::} ops), to evaluate performance against @code{JSON::Tiny}.
362 It is a drop-in replacement for @code{JSON::Tiny}'s from-json and to-json subs,
363 but it offers a few extra features.")
364 (license license:artistic2.0)))
366 (define-public perl6-json-marshal
368 (name "perl6-json-marshal")
374 (url "https://github.com/jonathanstowe/JSON-Marshal.git")
375 (commit (string-append "v" version))))
376 (file-name (git-file-name name version))
379 "0qy7j83h6gjzyyv74ncd92cd9h45rv8diaz3vldiv3b6fqwz4c6i"))))
380 (build-system rakudo-build-system)
382 `(("perl6-json-fast" ,perl6-json-fast)
383 ("perl6-json-name" ,perl6-json-name)))
385 `(("perl6-json-fast" ,perl6-json-fast)))
386 (home-page "https://github.com/jonathanstowe/JSON-Marshal")
387 (synopsis "Simple serialisation of objects to JSON")
388 (description "This library provides a single exported subroutine to create
389 a JSON representation of an object. It should round trip back into an object
390 of the same class using @code{JSON::Unmarshal}.")
391 (license license:artistic2.0)))
393 (define-public perl6-json-name
395 (name "perl6-json-name")
401 (url "https://github.com/jonathanstowe/JSON-Name.git")
402 (commit (string-append "v" version))))
403 (file-name (git-file-name name version))
406 "130qwdpbj5qdlsdz05y0rksd79lzbq79scy47n6lnf21b0hz1qjc"))))
407 (build-system rakudo-build-system)
408 (arguments '(#:with-zef? #f))
409 (home-page "https://github.com/jonathanstowe/JSON-Name")
410 (synopsis "Provides a trait to store an alternative JSON Name")
411 (description "This is released as a dependency of @code{JSON::Marshal} and
412 @code{JSON::Unmarshal} in order to save duplication, it is intended to store a
413 separate JSON name for an attribute where the name of the JSON attribute might be
414 changed, either for aesthetic reasons or the name is not a valid Perl identifier.
415 It will of course also be needed in classes thar are going to use
416 @code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
417 (license license:artistic2.0)))
419 (define-public perl6-json-unmarshal
420 ;; Last commit was May 2017
421 (let ((commit "e1b6288c5f3165058f36c0f4e171cdf2dfd640da")
424 (name "perl6-json-unmarshal")
425 (version (git-version "0.0.0" revision commit))
430 (url "https://github.com/tadzik/JSON-Unmarshal.git")
432 (file-name (git-file-name name version))
435 "14azsmzmwdn8k0gqcpvballharcvzylmlyrx2wmv4kpqfnz29fjc"))))
436 (build-system rakudo-build-system)
438 `(("perl6-json-fast" ,perl6-json-fast)
439 ("perl6-json-name" ,perl6-json-name)))
440 (home-page "https://github.com/tadzik/JSON-Unmarshal")
441 (synopsis "Make JSON from an Object")
442 (description "This library provides a single exported subroutine to
443 create an object from a JSON representation of an object.")
444 (license license:expat))))
446 (define-public perl6-license-spdx
448 (name "perl6-license-spdx")
454 (url "https://github.com/jonathanstowe/License-SPDX")
455 (commit (string-append "v" version))))
456 (file-name (git-file-name name version))
459 "0dl263c3fbxk001gm5fisrzqz1dx182ipaa0x2qva2gxvl075xm8"))))
460 (build-system rakudo-build-system)
462 `(("perl6-json-class" ,perl6-json-class)))
463 (home-page "https://github.com/jonathanstowe/License-SPDX")
464 (synopsis "Abstraction over the SPDX License List")
465 (description "This provides an abstraction over the SPDX License List as
466 provided in JSON format. Its primary raison d'être is to help the licence
467 checking of @code{Test::META} and to allow for the warning about deprecated
469 (license license:artistic2.0)))
471 (define-public perl6-meta6
479 (url "https://github.com/jonathanstowe/META6.git")
480 (commit (string-append "v" version))))
481 (file-name (git-file-name name version))
484 "1xnlaamfbdlfb2zidim3bbc4mawsrg6qxhxi6gbld46z1cyry1cw"))))
485 (build-system rakudo-build-system)
487 `(("perl6-json-class" ,perl6-json-class)))
489 `(("perl6-json-fast" ,perl6-json-fast)))
490 (home-page "https://github.com/jonathanstowe/META6")
491 (synopsis "Do things with Perl 6 [META files]")
492 (description "This provides a representation of the Perl 6 META files
493 specification - the META file data can be read, created, parsed and written in a
494 manner that is conformant with the specification.
496 Where they are known about it also makes allowance for customary usage in
497 existing software (such as installers and so forth.)
499 The intent of this is allow the generation and testing of META files for
500 module authors, so it can provide meta-information whether the attributes are
501 mandatory as per the spec and where known the places that customary attributes
503 (license license:artistic2.0)))
505 (define-public perl6-mime-base64
507 (name "perl6-mime-base64")
513 (url "https://github.com/perl6/Perl6-MIME-Base64")
514 (commit (string-append "v" version))))
515 (file-name (git-file-name name version))
518 "0l67m8mvz3gxml425sd1ggfnhzh4lf754k7w8fngfr453s6lsza1"))))
519 (build-system rakudo-build-system)
520 (arguments '(#:with-zef? #f))
521 (home-page "https://github.com/perl6/Perl6-MIME-Base64")
522 (synopsis "Encoding and decoding Base64 ASCII strings")
523 (description "This Perl 6 module implements encoding and decoding to and
525 (license license:artistic2.0)))
527 (define-public perl6-oo-monitors
529 (name "perl6-oo-monitors")
535 (url "https://github.com/jnthn/oo-monitors")
536 ;; The commit where 1.1 was "tagged"
537 (commit "494db3a3852854f30a80c9bd1489a7d5e429e7c5")))
538 (file-name (git-file-name name version))
541 "1sbw2x54wwjjanghjnc7ipmplaw1srvbrphsdv4ym6cipnbmbj9x"))))
542 (build-system rakudo-build-system)
543 (arguments '(#:with-zef? #f))
544 (home-page "https://github.com/jnthn/oo-monitors")
545 (synopsis "Monitors with condition variables for Perl 6")
546 (description "A monitor provides per-instance mutual exclusion for objects.
547 This means that for a given object instance, only one thread can ever be inside
548 its methods at a time. This is achieved by a lock being associated with each
549 object. The lock is acquired automatically at the entry to each method in the
550 monitor. Condition variables are also supported.")
551 (license license:artistic2.0)))
553 (define-public perl6-svg
554 ;; Latest commit, basically unchanged since August 2015
555 (let ((commit "07190c0602aa276e5319f06aa0012452dbff3582")
559 (version (git-version "0.0.0" revision commit))
564 (url "https://github.com/moritz/svg")
566 (file-name (git-file-name name version))
569 "0mkjdhg7ajksdn61n8fqhyzfd7ly9myazsvpsm02a5c2q73hdygg"))))
570 (build-system rakudo-build-system)
572 `(("perl6-xml-writer" ,perl6-xml-writer)))
573 (home-page "https://github.com/moritz/svg")
574 (synopsis "Perl 6 module to generate SVG")
575 (description "This is a Perl 6 module that makes it easy to write
576 @dfn{Scalable Vector Graphic files} (SVG). Right now it is a shallow wrapper
577 around @code{XML::Writer}, adding only the xmlns attributes that identifies an
579 (license license:artistic2.0))))
581 (define-public perl6-svg-plot
583 (let ((commit "062570a78fd38c3c6baba29dfe2fbb8ca014f4de")
586 (name "perl6-svg-plot")
587 (version (git-version "0.0.0" revision commit))
592 (url "https://github.com/moritz/svg-plot")
594 (file-name (git-file-name name version))
597 "095ga5hbg92jnmczxvhk1hjz14yr334zyf8cph4w5w5frcza44my"))))
598 (build-system rakudo-build-system)
600 `(("perl6-svg" ,perl6-svg)))
601 (home-page "https://github.com/moritz/svg-plot")
602 (synopsis "Perl 6 charting and plotting library that produces SVG output")
603 (description "@code{SVG::Plot} is a simple 2D chart plotter for Perl 6.
604 It currently supports bars, stacked bars, lines and points (both equally spaced
605 with optional labels, or xy plots).")
606 (license license:artistic2.0))))
608 (define-public perl6-tap-harness
610 (name "perl6-tap-harness")
616 (url "https://github.com/perl6/tap-harness6.git")
617 (commit (string-append "v" version))))
618 (file-name (git-file-name name version))
621 "1lig8i0my3fgqvlay9532xslbf3iis2d7wz89gniwvwqffi2kh6r"))))
622 (build-system rakudo-build-system)
627 (modify-phases %standard-phases
630 (invoke "perl6" "-Ilib" "bin/prove6" "-l" "t"))))))
631 (home-page "https://github.com/perl6/tap-harness6/")
632 (synopsis "TAP harness for perl6")
633 (description "This module provides the @command{prove6} command which runs a
634 TAP based test suite and prints a report. The @command{prove6} command is a
635 minimal wrapper around an instance of this module.")
636 (license license:artistic2.0)))
638 (define-public perl6-terminal-ansicolor
640 (name "perl6-terminal-ansicolor")
646 (url "https://github.com/tadzik/Terminal-ANSIColor.git")
647 ;; The commit where 0.5 was "tagged"
648 (commit "edded4a7116ce11cbc9fb5a83669c7ba119d0212")))
649 (file-name (git-file-name name version))
652 "1apm999azkyg5s35gid12wq019aqnvzrkz7qjmipd74mdxgr00x7"))))
653 (build-system rakudo-build-system)
654 (arguments '(#:with-zef? #f))
655 (home-page "https://github.com/tadzik/Terminal-ANSIColor")
656 (synopsis "Colorize terminal output")
657 (description "This is a @code{Terminal::ANSIColor} module for Perl 6.")
658 (license license:expat)))
660 (define-public perl6-test-meta
662 (name "perl6-test-meta")
668 (url "https://github.com/jonathanstowe/Test-META")
669 (commit (string-append "v" version))))
670 (file-name (git-file-name name version))
673 "1mzrglb7lbiy5h9dlc7dyhvv9gppxmdmpmrv6nzbd695jzr38bri"))))
674 (build-system rakudo-build-system)
676 `(("perl6-meta6" ,perl6-meta6)
677 ("perl6-uri" ,perl6-uri)))
678 (home-page "https://github.com/jonathanstowe/Test-META")
679 (synopsis "Test a distributions META file")
680 (description "This provides a simple mechanism for module authors to have
681 some confidence that they have a working distribution META description file.")
682 (license license:artistic2.0)))
684 (define-public perl6-test-mock
686 (name "perl6-test-mock")
692 (url "https://github.com/jnthn/test-mock")
693 ;; The commit where 1.5 was "tagged"
694 (commit "6eddb42f73f40b9ac29c14badb41ce4a04d876f2")))
695 (file-name (git-file-name name version))
698 "07yr3qimc8fl29p23562ayj2j9h53madcnf9sgqvgf2kcprh0zd2"))))
699 (build-system rakudo-build-system)
701 `(("perl6-oo-monitors" ,perl6-oo-monitors)))
702 (home-page "https://github.com/jnthn/test-mock")
703 (synopsis "Module for simply generating and checking mock objects")
704 (description "@code{Test::Mock} is a module that works alongside the
705 standard Test module to help you write tests when you want to verify what
706 methods are called on an object, while still having calls to undefined methods
707 die. You get started just as normal with the test file, but also add a use
708 statement for @code{Test::Mock}.")
709 (license license:artistic2.0)))
711 (define-public perl6-uri
719 (url "https://github.com/perl6-community-modules/uri.git")
721 (file-name (git-file-name name version))
724 "0h318g75jqn2ckw051g35iqyfxz1mps0jyg5z6pd857y3kacbkpl"))))
725 (build-system rakudo-build-system)
726 (arguments '(#:with-zef? #f))
727 (home-page "https://github.com/perl6-community-modules/uri")
728 (synopsis "URI implementation using Perl 6")
729 (description "A URI implementation using Perl 6 grammars to implement RFC
730 3986 BNF. Currently only implements parsing. Includes @code{URI::Escape} to
731 (un?)escape characters that aren't otherwise allowed in a URI with % and a hex
732 character numbering.")
733 (license license:artistic2.0)))
735 (define-public perl6-xml-writer
736 ;; Last commit was May 2017
737 (let ((commit "4d30a9d8e06033ca97387971b653817becd5a759")
740 (name "perl6-xml-writer")
741 (version (git-version "0.0.0" revision commit))
746 (url "https://github.com/masak/xml-writer")
748 (file-name (git-file-name name version))
751 "1kwrf7akp70kyzw1b90khp71a6hpilihwndy2jsjpffcd4hd4m4z"))))
752 (build-system rakudo-build-system)
753 (arguments '(#:with-zef? #f))
754 (home-page "https://github.com/masak/xml-writer")
755 (synopsis "Perl 6 module to generate XML")
756 (description "@code{XML::Writer} is a module for creating XML in Perl 6.")
757 (license license:artistic2.0))))
759 (define-public perl6-zef
767 (url "https://github.com/ugexe/zef.git")
768 (commit (string-append "v" version))))
769 (file-name (git-file-name name version))
772 "07n7g1xw2c4g860rs890gx85vyhdq0ysgwbrnzw6q905jph2bkv7"))))
773 (build-system rakudo-build-system)
777 (modify-phases %standard-phases
780 (setenv "HOME" "/tmp")
781 (invoke "perl6" "-I." "bin/zef" "--debug"
782 "--tap-harness" "test" "."))))))
783 (home-page "https://github.com/ugexe/zef")
784 (synopsis "Perl6 Module Management")
785 (description "Zef is a Perl 6 package (module) manager. It can be used to
786 download and install Perl 6 modules in your home directory or as a system-wide
788 (license license:artistic2.0)))