linux-container: Do not add %CONTAINER-FILE-SYSTEMS to Docker image OSes.
[guix.git] / gnu / packages / forth.scm
blob6902a4a4a3c889ad7ab25af6ccf26cdbad3a0413
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 ng0 <ng0@n0.is>
3 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages forth)
21   #:use-module ((guix licenses) #:prefix license:)
22   #:use-module (guix packages)
23   #:use-module (guix download)
24   #:use-module (guix build-system gnu)
25   #:use-module (gnu packages m4))
27 (define-public gforth
28   (package
29     (name "gforth")
30     (version "0.7.3")
31     (source (origin
32               (method url-fetch)
33               (uri (string-append "mirror://gnu/gforth/gforth-"
34                                   version ".tar.gz"))
35               (sha256
36                (base32
37                 "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig"))))
38     (build-system gnu-build-system)
39     (arguments
40      '(#:parallel-build? #f             ; XXX: parallel build fails
41        #:phases
42        (modify-phases %standard-phases
43          (add-after 'install 'install-gforth.el
44            (lambda* (#:key outputs #:allow-other-keys)
45              (let* ((out           (assoc-ref outputs "out"))
46                     (emacs-sitedir (string-append
47                                     out "/share/emacs/site-lisp")))
48                ;; TODO: compile and autoload it.
49                (install-file "gforth.el" emacs-sitedir)
50                #t))))))
51     (native-inputs
52      `(("m4" ,m4)))
53     (synopsis "Forth interpreter")
54     (description
55      "Gforth is a fast and portable implementation of the ANSI Forth language.
56 It includes an editing mode for Emacs and an interpreter featuring completion
57 and history.  A generic virtual machine environment, vmgen, is also
58 included.")
59     (home-page "https://www.gnu.org/software/gforth/")
60     (license license:gpl3+)))