linux-container: Do not add %CONTAINER-FILE-SYSTEMS to Docker image OSes.
[guix.git] / gnu / packages / ada.scm
bloba8c2bdc9a9b3b5e73c6f429c259cf11d1233b053
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages ada)
20   #:use-module ((guix licenses) #:prefix license:)
21   #:use-module (guix build-system gnu)
22   #:use-module (guix build-system python)
23   #:use-module (guix packages)
24   #:use-module (guix download)
25   #:use-module (guix git-download)
26   #:use-module (gnu packages)
27   #:use-module (gnu packages check)
28   #:use-module (gnu packages compression)
29   #:use-module (gnu packages python)
30   #:use-module (gnu packages python-xyz))
32 (define-public python2-langkit
33   (let ((commit "fe0bc8bf60dbd2937759810df76ac420d99fc15f")
34         (revision "0"))
35     (package
36       (name "python2-langkit")
37       (version (git-version "0.0.0" revision commit))
38       (source (origin
39                 (method git-fetch)
40                 (uri (git-reference
41                       (url "https://github.com/AdaCore/langkit.git")
42                       (commit commit)))
43                 (sha256
44                  (base32
45                   "1abqgw2p8pb1pm54my5kkbbixfhc6l0bwajdv1xlzyrh31xki3wx"))
46                 (file-name (string-append name "-" version "-checkout"))))
47       (build-system python-build-system)
48       (propagated-inputs
49        `(("python2-docutils" ,python2-docutils)
50          ("python2-enum34" ,python2-enum34)
51          ("python2-funcy" ,python2-funcy)
52          ("python2-mako" ,python2-mako)))
53       (arguments
54        `(#:python ,python-2
55          #:tests? #f))           ; Tests would requite gprbuild (Ada).
56       (synopsis "Semantic analysis tool generator in Python")
57       (description "@code{Langkit} is a tool whose purpose is to make it easy
58 to create syntactic and semantic analysis engines.  Write a language
59 specification in our Python DSL and Langkit will generate for you an
60 Ada library with bindings for the C and Python programming languages.")
61       (home-page "https://github.com/AdaCore/langkit/")
62       (license license:gpl3+))))   ; and gcc runtime library exception
64 (define-public python2-libadalang
65   (let ((commit "9b205e9bacdd50a68117727332e16fbef5f6ac49")
66         (revision "0"))
67     (package
68       (name "python2-libadalang")
69       (version (git-version "0.0.0" revision commit))
70       (source (origin
71                 (method git-fetch)
72                 (uri (git-reference
73                       (url "https://github.com/AdaCore/libadalang.git")
74                       (commit commit)))
75                 (sha256
76                  (base32
77                   "06hsnzj2syqpq2yhg1bb0zil7ydbyqkdmkjbf8j9b5sdgkyh5xrp"))
78                 (file-name (string-append name "-" version "-checkout"))))
79       (build-system python-build-system)
80       (native-inputs
81        `(("python2-langkit" ,python2-langkit)
82          ("python2-quex" ,python2-quex-0.67.3)))
83       (arguments
84        `(#:python ,python-2
85          #:phases
86          (modify-phases %standard-phases
87            (replace 'build
88              (lambda _
89                (invoke "python2" "ada/manage.py" "generate")
90                (invoke "python2" "ada/manage.py" "build")))
91            (replace 'check
92              (lambda _
93                (invoke "python2" "ada/manage.py" "test")))
94            (replace 'install
95              (lambda* (#:key outputs #:allow-other-keys)
96                (let* ((out (assoc-ref outputs "out")))
97                  (invoke "python2" "ada/manage.py" "install" out)))))))
98       (synopsis "Semantic Analysis for Ada in Python")
99       (description "@code{libadalang} provides a high-performance semantic
100 engine for the Ada programming language.")
101       (home-page "https://github.com/AdaCore/libadalang")
102       (license license:gpl3)))) ; and gcc runtime gcc lib exception