1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
7 ;;; This file is part of GNU Guix.
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22 (define-module (gnu packages vpn)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages gettext)
30 #:use-module (gnu packages gnupg)
31 #:use-module (gnu packages linux)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages tls)
35 #:use-module (gnu packages xml))
43 (uri (string-append "mirror://gnu/gvpe/gvpe-"
47 "1gsipcysvsk80gvyn9jnk9g0xg4ng9yd5zp066jnmpgs52d2vhvk"))))
48 (build-system gnu-build-system)
49 (home-page "http://software.schmorp.de/pkg/gvpe.html")
50 (inputs `(("openssl" ,openssl)
52 (synopsis "Secure VPN among multiple nodes over an untrusted network")
54 "The GNU Virtual Private Ethernet creates a virtual network
55 with multiple nodes using a variety of transport protocols. It works
56 by creating encrypted host-to-host tunnels between multiple
58 (license license:gpl3+)))
66 (uri (string-append "https://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
69 "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))
70 (patches (list (search-patch "vpnc-script.patch")))))
71 (build-system gnu-build-system)
72 (inputs `(("libgcrypt" ,libgcrypt)
75 `(#:tests? #f ; there is no check target
79 (lambda* (#:key outputs #:allow-other-keys)
80 (let ((out (assoc-ref outputs "out")))
81 (substitute* "Makefile"
82 (("PREFIX=/usr/local") (string-append "PREFIX=" out)))
83 (substitute* "Makefile"
84 (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out "/etc/vpnc")))))
86 (synopsis "Client for Cisco VPN concentrators")
88 "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
89 It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
90 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
91 1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
92 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
93 (license license:gpl2+) ; some file are bsd-2, see COPYING
94 (home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
97 (define-public openconnect
103 (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
104 "openconnect-" version ".tar.gz"))
106 "1i102yr8yp2ny587n6pd966443h1pqxyw5q0n5afq575046jj98g"))))
107 (build-system gnu-build-system)
109 `(("libxml2" ,libxml2)
114 `(("gettext" ,gnu-gettext)
115 ("pkg-config" ,pkg-config)))
118 `(,(string-append "--with-vpnc-script="
119 (assoc-ref %build-inputs "vpnc")
120 "/etc/vpnc/vpnc-script"))))
121 (synopsis "Client for Cisco VPN")
123 "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
124 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
125 870, 880, 1800, 2800, 3800, 7200 Series and Cisco 7301 Routers,
126 and probably others.")
127 (license license:lgpl2.1)
128 (home-page "http://www.infradead.org/openconnect/")))
130 (define-public openvpn
137 "https://swupdate.openvpn.org/community/releases/openvpn-"
141 "1v8h2nshxnvn2zyr08vzkfby1kc7ma6bi0s6hix389cj9krjxbmd"))))
142 (build-system gnu-build-system)
144 '(#:configure-flags '("--enable-iproute2=yes")))
146 `(("iproute2" ,iproute)))
150 ("linux-pam" ,linux-pam)))
151 (home-page "https://openvpn.net/")
152 (synopsis "Virtual private network daemon")
153 (description "OpenVPN implements virtual private network (VPN) techniques
154 for creating secure point-to-point or site-to-site connections in routed or
155 bridged configurations and remote access facilities. It uses a custom
156 security protocol that utilizes SSL/TLS for key exchange. It is capable of
157 traversing network address translators (NATs) and firewalls.")
158 (license license:gpl2)))
166 (uri (string-append "http://tinc-vpn.org/packages/"
167 name "-" version ".tar.gz"))
170 "08ds8s32cjslms1q227ihd6jz35583v378ij4pknfa5xngfijhrb"))))
171 (build-system gnu-build-system)
174 '("--sysconfdir=/etc"
175 "--localstatedir=/var")))
176 (inputs `(("zlib" ,zlib)
178 ("openssl" ,openssl)))
179 (home-page "http://tinc-vpn.org")
180 (synopsis "Virtual Private Network (VPN) daemon")
182 "Tinc is a VPN that uses tunnelling and encryption to create a secure
183 private network between hosts on the internet.")
184 (license license:gpl2+)))