services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / slang.scm
bloba00fa7b01e9b8a4a7fa97ad4d5362e90f58c5506
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages slang)
21   #:use-module (guix packages)
22   #:use-module (guix download)
23   #:use-module (guix build-system gnu)
24   #:use-module ((guix licenses) #:prefix license:)
25   #:use-module (gnu packages readline)
26   #:use-module (gnu packages ncurses)
27   #:use-module (gnu packages popt)
28   #:use-module (gnu packages fribidi)
29   #:use-module (gnu packages compression)
30   #:use-module (gnu packages image)
31   #:use-module (gnu packages pcre))
33 (define-public slang
34   (package
35     (name "slang")
36     (version "2.3.0")
37     (source (origin
38               (method url-fetch)
39               (uri (string-append
40                     "http://www.jedsoft.org/releases/slang/slang-"
41                     version
42                     ".tar.gz"))
43               (sha256
44                (base32
45                 "0aqd2cjabj6nhd4r3dc4vhqif2bf3dmqnrn2gj0xm4gqyfd177jy"))
46               (modules '((guix build utils)))
47               (snippet
48                '(begin
49                   (substitute* "src/Makefile.in"
50                     (("/bin/ln") "ln"))
51                   (substitute* "configure"
52                     (("-ltermcap") ""))))))
53     (build-system gnu-build-system)
54     (arguments
55      '(#:parallel-tests? #f
56        #:parallel-build? #f)) ; there's at least one race
57     (inputs
58      `(("readline" ,readline)
59        ("zlib" ,zlib)
60        ("libpng" ,libpng)
61        ("pcre" ,pcre)
62        ("ncurses" ,ncurses)))
63     (home-page "http://www.jedsoft.org/slang/")
64     (synopsis "Library for interactive applications and extensibility")
65     (description
66      "S-Lang is a multi-platform programmer's library designed to allow a
67 developer to create robust multi-platform software.  It provides facilities
68 required by interactive applications such as display/screen management,
69 keyboard input, keymaps, and so on.  The most exciting feature of the library
70 is the slang interpreter that may be easily embedded into a program to make it
71 extensible.  While the emphasis has always been on the embedded nature of the
72 interpreter, it may also be used in a stand-alone fashion through the use of
73 slsh, which is part of the S-Lang distribution.")
74     (license license:gpl2+)))
76 (define-public newt
77   (package
78     (name "newt")
79     (version "0.52.18")
80     (source (origin
81               (method url-fetch)
82               (uri (string-append "https://fedorahosted.org/releases/n/e/"
83                                   name "/" name "-" version ".tar.gz"))
84               (sha256
85                (base32
86                 "07n9f2mqsjfj35wx5ldhvl9sqcjqpcl0g4fdd9mawmny9rihw6vp"))))
87     (build-system gnu-build-system)
88     (inputs
89      `(("slang" ,slang)
90        ("popt" ,popt)
91        ("fribidi" ,fribidi)))
92     (arguments
93      `(#:tests? #f    ; no test suite
94        #:configure-flags
95        ;; Set the correct RUNPATH in binaries.
96        (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
97        #:phases
98        (modify-phases %standard-phases
99          (add-after
100           'unpack 'patch-/usr/bin/install
101           (lambda _
102             (substitute* "po/Makefile"
103               (("/usr/bin/install") "install"))
104             #t)))))
105     (home-page "https://fedorahosted.org/newt/")
106     (synopsis "Not Erik's Windowing Toolkit - text mode windowing with slang")
107     (description
108      "Newt is a windowing toolkit for text mode built from the slang library.
109 It allows color text mode applications to easily use stackable windows, push
110 buttons, check boxes, radio buttons, lists, entry fields, labels, and
111 displayable text.  Scrollbars are supported, and forms may be nested to
112 provide extra functionality.")
113     (license license:lgpl2.0)))