1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;; This file is part of GNU Guix.
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages slang)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages readline)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages popt)
28 #:use-module (gnu packages fribidi)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages pcre))
40 "http://www.jedsoft.org/releases/slang/slang-"
45 "0aqd2cjabj6nhd4r3dc4vhqif2bf3dmqnrn2gj0xm4gqyfd177jy"))
46 (modules '((guix build utils)))
49 (substitute* "src/Makefile.in"
51 (substitute* "configure"
52 (("-ltermcap") ""))))))
53 (build-system gnu-build-system)
55 '(#:parallel-tests? #f
56 #:parallel-build? #f)) ; there's at least one race
58 `(("readline" ,readline)
62 ("ncurses" ,ncurses)))
63 (home-page "http://www.jedsoft.org/slang/")
64 (synopsis "Library for interactive applications and extensibility")
66 "S-Lang is a multi-platform programmer's library designed to allow a
67 developer to create robust multi-platform software. It provides facilities
68 required by interactive applications such as display/screen management,
69 keyboard input, keymaps, and so on. The most exciting feature of the library
70 is the slang interpreter that may be easily embedded into a program to make it
71 extensible. While the emphasis has always been on the embedded nature of the
72 interpreter, it may also be used in a stand-alone fashion through the use of
73 slsh, which is part of the S-Lang distribution.")
74 (license license:gpl2+)))
82 (uri (string-append "https://fedorahosted.org/releases/n/e/"
83 name "/" name "-" version ".tar.gz"))
86 "07n9f2mqsjfj35wx5ldhvl9sqcjqpcl0g4fdd9mawmny9rihw6vp"))))
87 (build-system gnu-build-system)
91 ("fribidi" ,fribidi)))
93 `(#:tests? #f ; no test suite
95 ;; Set the correct RUNPATH in binaries.
96 (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
98 (modify-phases %standard-phases
100 'unpack 'patch-/usr/bin/install
102 (substitute* "po/Makefile"
103 (("/usr/bin/install") "install"))
105 (home-page "https://fedorahosted.org/newt/")
106 (synopsis "Not Erik's Windowing Toolkit - text mode windowing with slang")
108 "Newt is a windowing toolkit for text mode built from the slang library.
109 It allows color text mode applications to easily use stackable windows, push
110 buttons, check boxes, radio buttons, lists, entry fields, labels, and
111 displayable text. Scrollbars are supported, and forms may be nested to
112 provide extra functionality.")
113 (license license:lgpl2.0)))