services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / pumpio.scm
blob22c631edf990095b56117113bd6a6b588e0425bd
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages pumpio)
20   #:use-module (guix licenses)
21   #:use-module (guix packages)
22   #:use-module (guix download)
23   #:use-module (guix git-download)
24   #:use-module (guix build-system gnu)
25   #:use-module (gnu packages aspell)
26   #:use-module (gnu packages kde)
27   #:use-module (gnu packages qt)
28   #:use-module (gnu packages web))
30 (define-public pumpa
31   (package
32     (name "pumpa")
33     (version "0.9.1")
34     (source (origin
35               (method git-fetch) ; no source tarballs
36               (uri (git-reference
37                     (url "git://pumpa.branchable.com/")
38                     (commit (string-append "v" version))))
39               (sha256
40                (base32
41                 "14s0m46yqph8bs5rjpmiq42f020j9l3mygan2zj93z6qzypwd07f"))))
42     (build-system gnu-build-system)
43     (arguments
44      '(#:phases (alist-replace
45                  'configure
46                  (lambda* (#:key inputs outputs #:allow-other-keys)
47                    ;; Fix dependency tests.
48                    (substitute* "pumpa.pro"
49                      (("/usr/include/tidy\\.h")
50                       (string-append (assoc-ref inputs "tidy")
51                                      "/include/tidy.h"))
52                      (("/usr/include/aspell.h")
53                       (string-append (assoc-ref inputs "aspell")
54                                      "/include/aspell.h")))
55                    ;; Run qmake with proper installation prefix.
56                    (let ((prefix (string-append "PREFIX="
57                                                 (assoc-ref outputs "out"))))
58                      (zero? (system* "qmake" prefix))))
59                  %standard-phases)))
60     (inputs
61      `(("aspell" ,aspell)
62        ("qt" ,qt)
63        ("qjson" ,qjson)
64        ("tidy" ,tidy)))
65     (synopsis "Qt-based pump.io client")
66     (description "Pumpa is a simple pump.io client written in C++ and Qt.")
67     (home-page "https://pumpa.branchable.com/")
68     (license gpl3+)))