1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages ots)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages compression)
22 #:use-module (gnu packages glib)
23 #:use-module (gnu packages pkg-config)
24 #:use-module (gnu packages popt)
25 #:use-module (gnu packages xml)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu)
29 #:use-module ((guix licenses) #:prefix license:))
38 (uri (string-append "mirror://sourceforge/libots/libots/"
39 name "-" version "/" name "-" version
42 (base32 "0dz1ccd7ymzk4swz1aly4im0k3pascnshmgg1whd2rk14li8v47a"))
44 (list (search-patch "ots-no-include-missing-file.patch")))))
46 (build-system gnu-build-system)
48 ;; With '-jN', the rule to build the 'ots' command can be triggered
49 ;; before libots-1.la has been built.
50 '(#:parallel-build? #f
52 #:phases (alist-cons-after
53 'configure 'set-shared-lib-extension
55 ;; For some reason, the 'libtool' script (from Libtool
56 ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
57 ;; 'shrext' for the shared library file name extension.
58 ;; This leads to the creation of 'libots-1' instead of
59 ;; 'libots-1.so'. Fix that.
60 (substitute* "libtool"
61 (("shrext_cmds") "shrext")))
69 `(("glib:bin" ,glib "bin")
70 ("pkg-config" ,pkg-config)))
71 (synopsis "Tool for summarizing texts")
73 "The Open Text Summarizer is a library and command-line tool for
74 summarizing texts. The program reads a text and decides which sentences are
75 important and which are not. OTS will create a short summary or will
76 highlight the main ideas in the text.
78 The program can either print the summarized text as plain text or HTML. If in
79 HTML, the important sentences are highlighted.
81 The program is multi lingual and works with UTF-8 encoding.")
82 (home-page "http://libots.sourceforge.net/")
83 (license license:gpl2+)))