services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / mtools.scm
blobca8af84fc3a5f5ec947ecadb46c010ea1592417c
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages mtools)
21   #:use-module (guix licenses)
22   #:use-module (guix packages)
23   #:use-module (guix download)
24   #:use-module (guix build-system gnu)
25   #:use-module (gnu packages python))
27 (define-public mtools
28   (package
29     (name "mtools")
30     (version "4.0.18")
31     (source
32      (origin
33       (method url-fetch)
34       (uri (string-append "mirror://gnu/mtools/mtools-"
35                           version ".tar.gz"))
36       (sha256
37        (base32
38         "1hxciksv7av5ilnkvwbidyxxr1gzn24lr0mz9z8drkml7780im1h"))))
39     (build-system gnu-build-system)
40     (home-page "https://www.gnu.org/software/mtools/")
41     (synopsis "Access MS-DOS disks without mounting")
42     (description
43      "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
44 or Unix system.  It supports long file names and multiple disk formats.  It
45 also supports some FAT-specific features such as volume labels and
46 FAT-specific file attributes.")
47     (license gpl3+)))
49 (define-public exfat-utils
50   (package
51     (name "exfat-utils")
52     (version "1.1.1")
53     (source (origin
54               (method url-fetch)
55               (uri "https://docs.google.com/uc?export=download&\
56 id=0B7CLI-REKbE3UzNtSkRvdHBpdjQ")
57               (sha256
58                (base32
59                 "0ck2snhlhp965bb9a4y1g2lpl979sw1yznm79wbavyv174458i66"))
60               (file-name (string-append name "-" version ".tar.gz"))))
61     (build-system gnu-build-system)
62     (native-inputs `(("scons" ,scons)))
63     (arguments
64      '(#:tests? #f                                ;no test suite
65        #:phases (modify-phases %standard-phases
66                   (delete 'configure)
67                   (add-after 'unpack 'scons-propagate-environment
68                              (lambda _
69                                ;; Modify the SConstruct file to arrange for
70                                ;; environment variables to be propagated.
71                                (substitute* "SConstruct"
72                                  (("^env = Environment\\(")
73                                   "env = Environment(ENV=os.environ, "))))
74                   (replace 'build
75                            (lambda _
76                              (zero? (system* "scons"))))
77                   (replace 'install
78                            (lambda* (#:key outputs #:allow-other-keys)
79                              (let* ((out  (assoc-ref outputs "out"))
80                                     (bin  (string-append out "/bin"))
81                                     (man8 (string-append out
82                                                          "/share/man/man8")))
83                                (mkdir-p bin)
84                                (mkdir-p man8)
85                                (for-each (lambda (file)
86                                            (copy-file
87                                             file
88                                             (string-append man8 "/"
89                                                            (basename file))))
90                                          (find-files "." "\\.8$"))
91                                (zero? (system* "scons" "install"
92                                                (string-append "DESTDIR="
93                                                               bin)))))))))
94     (home-page "https://code.google.com/p/exfat")
95     (synopsis "Utilities to manipulate exFAT file systems")
96     (description
97      "This package provides an implementation of the exFAT file system,
98 including command-line tools to validate exFAT file systems and to create new
99 ones.")
100     (license gpl2+)))