services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / mg.scm
bloba315dfed336c42cd13c9d5f4becd47f9e0d1dfe1
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages mg)
20   #:use-module (guix licenses)
21   #:use-module (guix download)
22   #:use-module (guix packages)
23   #:use-module (guix build-system gnu)
24   #:use-module (gnu packages ncurses)
25   #:use-module (gnu packages pkg-config))
27 (define-public mg
28   (package
29     (name "mg")
30     (version "20050429")
31     (source (origin
32               (method url-fetch)
33               (uri (string-append "http://homepage.boetes.org/software/mg/mg-"
34                                   version ".tar.gz"))
35               (sha256
36                (base32
37                 "19kib0aha4a40izzds7r63qfb2akq4sily6k28fl0n0zdgq0cna1"))
38               (modules '((guix build utils)))
39               (snippet
40                '(begin
41                   (substitute* "Makefile.in"
42                     (("-Werror") "")
43                     (("-lcurses") "-lncurses")
44                     (("/usr/bin/install") "install -D")
45                     (("/usr/bin/strip") "strip"))))))
46     (build-system gnu-build-system)
47     (inputs
48      `(("ncurses" ,ncurses)))
49     (arguments
50      ;; No test suite available.
51      '(#:tests? #f
52        #:phases (alist-cons-before
53                  'configure 'pre-configure
54                  (lambda* (#:key outputs #:allow-other-keys)
55                    (substitute* "Makefile.in"
56                      (("(prefix=[[:blank:]]*)/usr/local" all prefix)
57                       (string-append prefix (assoc-ref outputs "out")))))
58                  %standard-phases)))
59     (home-page "http://homepage.boetes.org/software/mg/")
60     (synopsis "Microscopic GNU Emacs clone")
61     (description
62      "mg is Micro GNU Emacs; this is a portable version of the mg maintained
63 by the OpenBSD team.")
64     (license public-domain)))