1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages jemalloc)
20 #:use-module ((guix licenses) #:select (bsd-2))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages gcc)
25 #:use-module (guix build-system gnu))
27 (define-public jemalloc
34 "http://www.canonware.com/download/jemalloc/"
35 name "-" version ".tar.bz2"))
38 "1zl4vxxjvhg72bdl53sl0idz9wp18c6yzjdmqcnwm09wvmcj2v71"))))
39 (build-system gnu-build-system)
40 ;; XXX FIXME: Use gcc-4.8 on i686 to work around
41 ;; <http://bugs.gnu.org/20856>.
42 (native-inputs (if (and (not (%current-target-system))
43 (string-prefix? "i686-" (%current-system)))
44 `(("gcc" ,(canonical-package gcc-4.8)))
46 (home-page "http://www.canonware.com/jemalloc/")
47 (synopsis "General-purpose scalable concurrent malloc implementation")
49 "This library providing a malloc(3) implementation that emphasizes
50 fragmentation avoidance and scalable concurrency support.")