1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;; This file is part of GNU Guix.
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages icu4c)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages perl)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
34 (uri (string-append "http://download.icu-project.org/files/icu4c/"
37 (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
40 (base32 "0ys5f5spizg45qlaa31j2lhgry0jka2gfha527n4ndfxxz5j4sz1"))
41 (patches (map search-patch '("icu4c-CVE-2014-6585.patch"
42 "icu4c-CVE-2015-1270.patch"
43 "icu4c-CVE-2015-4760.patch")))))
44 (build-system gnu-build-system)
50 ,@(if (string-prefix? "arm" (or (%current-target-system)
52 '("--with-data-packaging=archive")
56 'unpack 'chdir-to-source
57 (lambda _ (chdir "source"))
59 'configure 'patch-configure
61 ;; patch out two occurrences of /bin/sh from configure script
62 ;; that might have disappeared in a release later than 54.1
63 (substitute* "configure"
65 (string-append "`" (which "bash")))))
67 (synopsis "International Components for Unicode")
69 "ICU is a set of C/C++ and Java libraries providing Unicode and
70 globalisation support for software applications. This package contains the
73 (home-page "http://site.icu-project.org/")))