1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages gxmessage)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages glib)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages))
29 (define-public gxmessage
35 (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
38 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
39 (build-system gnu-build-system)
43 `(("intltool" ,intltool)
44 ("pkg-config" ,pkg-config)))
45 (home-page "http://www.gnu.org/software/gxmessage/")
46 (synopsis "Open popup message window with buttons for return")
47 (description "GNU gxmessage is a program that pops up dialog windows, which display
48 a message to the user and waits for their action. The program then exits
49 with an exit code corresponding to the response.")