services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / gv.scm
blob5f8532144b63542080ca7c1d917c87851bcc2cc9
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages gv)
21   #:use-module (gnu packages)
22   #:use-module (gnu packages ghostscript)
23   #:use-module (gnu packages compression)
24   #:use-module (gnu packages pkg-config)
25   #:use-module (gnu packages xorg)
26   #:use-module ((guix licenses) #:prefix license:)
27   #:use-module (guix packages)
28   #:use-module (guix download)
29   #:use-module (guix build-system gnu))
31 (define-public gv
32   (package
33    (name "gv")
34    (version "3.7.4")
35    (source (origin
36             (method url-fetch)
37             (uri (string-append "mirror://gnu/gv/gv-"
38                                 version ".tar.gz"))
39             (sha256 (base32
40                      "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
41    (build-system gnu-build-system)
42    (propagated-inputs `(("ghostscript" ,ghostscript/x)))
43    (inputs `(("libx11" ,libx11)
44              ("libxaw3d" ,libxaw3d)
45              ("libxinerama" ,libxinerama)
46              ("libxpm" ,libxpm)
47              ("zlib" ,zlib)))
48    (native-inputs
49      `(("pkg-config" ,pkg-config)))
50    (synopsis "PostScript and PDF viewer using Ghostscript as a back-end")
51    (description
52     "GNU GV is a graphical user interface to the Ghostscript interpreter.
53 With it, one can view and navigate through PostScript and PDF documents in X
54 Windows.")
55    (license license:gpl3+)
56    (home-page "http://www.gnu.org/software/gv/")))